Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I was not happy about the choice of texlive 2009 from Ubuntu repositories, I installed texlive 2012 manually from the website.

Secondly, I like Kile to write, but when I try to install it, it forces me to install all the packages that i want to avoid (2009 version). So I used equivs and made a dummy Ubuntu package that tricks the OS (Ubuntu 12.04 64-bit) into installing kile without those packages.

The problem is that Kile refuses to compile.

When I try to do it, from the output I can see that he does:

  • cd into the right directory
  • executes the pdflatex command

And that's it. The funny thing is that repeating the same exact command via the terminal, the file is compiled correctly (I updated correctly the PATH, after all).

Any ideas on how can I get it to work again?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I had updated the PATH only via .bashrc. With a rapid check of "Settings > Check System" it showed up that he did not know where to look for the binaries.

I solved by adding /usr/local/texlive/2012/bin/x86_64-linux to /etc/environment

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.