Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I installed Ubuntu 12.04 Gnome Shell Remix 64bit on my desktop, everything was going great on it. I installed all of the most recent updates, installed some software as well as the latest amd graphics driver 12.6. Everything worked perfectly, I had rebooted the system several times switching back and forth between windows 7. The issue began when I installed Cube 2: Sauerbraten. The game played nicely until I changed to fullscreen, then the resolution changed to 640x480, even though I set it to 1920X1080. The system became entirely unresponsive, I hit "ctrl-alt-f2" and logged in and "sudo service lightdm stop" and "sudo service lightdm start" but it returned me to an all blue screen. I finally reboot the computer but now immediately after the bios I see the grub menu where I have the option of booting kernel 3.2 the 3.2 recovery mode and windows 7. Chosing to boot kernel 3.2 sends me back to the blue screen, but the recovery does work and shows the usual options. How can I go about restore my system, I have found many similar solutions on this site but none make a difference.

share|improve this question
    
I assume if you choose Windows 7 at boot, it will boot fine, does it? If not you should check your hardware. –  LiveWireBT Jul 14 '12 at 12:46
    
Opps forgot to include that, yes Windows works perfectly fine –  Shingaling Jul 14 '12 at 13:27
add comment

3 Answers

I would try moving the file /etc/X11/xorg.conf to /etc/X11/xorg.conf.backup. You can do that in recovery mode or from a LiveCD.

If that doesn't fix the problem, you may have no choice but to reinstall from the LiveCD. If you have to reinstall, I think there is an option to preserve the files and folders of your /home directory.

As a tip- When systems screw up, it is a good idea to have /home on a different partition.

share|improve this answer
    
Well I just did that, but it made no difference...Perhaps uninstalling fglrx may help? –  Shingaling Jul 14 '12 at 22:12
    
If you run this ls -t /var/lib/dpkg/info/*list | head -n 40, it will display the last 40 packages you installed on your system. You may have luck with uninstalling the last packages you installed, but have to admit that I am very skeptical that this will work. –  Sepero Jul 14 '12 at 22:23
    
I tried it, but unfortunately it didn't help. Thank you though –  Shingaling Jul 15 '12 at 10:10
add comment

I discovered the issue with my computer, it turns out my hard drive was failing and a few sectors where important system files was located had failed, thus preventing the system from loading properly. Since then I purchased a 32gb solid state drive and have my /home partition on a 1tb hard drive.

share|improve this answer
add comment

Try removing ~/.config/monitors.xml from the console, then try again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.