Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I boot into Ubuntu, I don't see the Unity interface. Instead it boots into some sort of command line interface (pic attached) What the screen shows

I tried pressing atl + F7, in that case i get a screen showing this: On pressing Atl + F7

Ubuntu was working properly before. I am using propriety graphics drivers from ATI. link to graphics driver. The problem surfaced after I ran software update yesterday.

I'm sorry for the bad quality screenshots. I am not sure how to take screen grabs in this situation.

"If" this is caused because of me using the propriety graphics drivers, how do I solve it? or else, What else can possibly be the issue?

share|improve this question
    
What happens if you type startx when logged into terminal? –  Andrew Jan 12 '13 at 7:29

3 Answers 3

I had a very similar issue after an update in 12.10, not sure if this might apply to your issue directly. Searching here did not resolve my issue, but then I found a workaround on my own. I looked up the running processes where I found lightdm (light display manager) which is used by Ubuntu for the login screen.

simply restarting it was working fine for me and I was able to continue with updates and whatsoever.

ps -aux | grep lightdm
sudo killall lightdm
sudo lightdm
share|improve this answer

The gui is not able to run because of some problem with the driver you installed. The lightdm is unable to load. To correct the situation:

  • Press ctrl+Alt+f1 to switch to the tty and login
  • sudo apt-get remove --purge [the driver you installed]
    The name would probably be fglrx and some similar name starting with fglrx. Do a web search. The instructions on the amd website should be helpful too on how to uninstall the drivers.
  • Assuming you are able to connect to Internet, you should install the drivers available in the repository. Even After installing these drivers, if things don't work you should search for how to reinstall lightdm.

Sorry for vague instructions. I hope it helps

share|improve this answer
1  
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* for uninstall driver. –  Kaktarua Jul 14 '12 at 9:03
    
tried it. didn't work. Now when I press Alt + F7, I just get a blank screen. –  sumit_gt Jul 14 '12 at 11:36

Please try these steps. Or go there for more info

  • Hit ctrl+alt+F1 at the blank screen to get you to a non-X terminal (tty1)
  • Login in with your username and password
  • Change to root with: sudo -i and enter your password
  • mkdir -p /run /run/lock
  • rm -rf /var/run /var/lock
  • ln -s /run /var
  • ln -s /run/lock /var
  • reboot

UPDATE:

I have found this info about your problem. You are not able to login into GUI because something gone wrong with your video card driver. It may happens after an unsuccessful UPDATE. I was faced that situation few weeks ago. And I recovered it by installing my system again. :) But now i found this steps that can help to gain gui again.

In your tty1 login screen. Login in with your user and password.

Then go to /etc/X11 directory by typing cd /etc/X11

Then rename xorg.conf to some thing like axorg.conf because this file responsible for video driver information. Don't worry we will restore it again if anything bad happens. Type

mv xorg.conf axrog.conf

sudo reboot

Now, if you get the GUI, then it works. Update your driver manually or go for an upgrade.

sudo apt-get upgrade

If you want to update driver manually then search for the right driver and install it through apt.

share|improve this answer
    
This this, still won't work. –  sumit_gt Jul 14 '12 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.