Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It appears that regardless what I set in the Shadow Window field in Windows Decoration preferences, Compiz ignores the setting and would still draw shadows under windows. What I set in the field seems to only affect other elements like menus and tool tips. Also, I've rid all the shadow tags in the theme I'm using so I'm pretty sure the shadow isn't coming from the theme itself.

Is this a bug or by design?

share|improve this question
    
Sorry, I missed the last line now in bold. Can you edit your question to add what base theme it is? Also, read Compiz's Window Matching page to identify any windows still with shadows. Add something like any | (class=Tooltip | Menu | PopupMenu | DropdownMenu | Unknown) in the Shadow windows field to see if that helps. If not, keep editing your question with any new info. It's probably something simple that we're all overlooking. Edit: just saw this, it may help too. –  Tom Brossman Jul 14 '12 at 11:51
1  
@Flint: have you looked at my answer? Do you have any other questions I can help with? –  izx Jul 17 '12 at 7:26
add comment

1 Answer

up vote 1 down vote accepted

I'm pretty sure the behavior is by design; there used to be a comment in the Compiz code saying that the Shadow filters only apply to windows that are not decorated. The old Metacity workarounds no longer work (although they may still in Unity 2D, which uses Metacity).

  1. So, disabling Shadows on any window (here, CCSM itself) has no effect as long as it is decorated:

    enter image description here

  2. But if you also disable Decoration, the shadows are gone (as are the titlebars ;):

    enter image description here

  3. Workaround: to "disable" shadows, just make them transparent:

    enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.