Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing xplanet today, but when I run the application, nothing happens.

I had it running some years ago and I remember that maybe I have to convince the ubuntu desktop manager to accept the drawn wallpaper from another application, but don't know how I can set this in Ubuntu now.

Any advice or URLs for me?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Note:

  • xplanet is rather old software. It doesn't work properly when desktop effects are enabled. To test this, first disable desktop effects via System → Appearance:

If you can't get it to work with desktop effects, but it works without them, consider asking another question about it.


Now, onto the problem:

From xplanet's package description:

In order to run xplanet, you'll need at least one map file. Some maps are included in the xplanet-images package

The images used by xplanet are stored in ~/.xplanet/images/ (where ~ is short-hand for your Home Directory; files and folders that start with a . are hidden, you can make Nautilus show them by pressing Ctrl+H, again that's Your home directory → .xplanet → images)

  • To see if it worked, type*

    xplanet -window
    

    into a terminal. (I've tested this, but if you get any errors, add them to your - question).

  • Now, to show xplanet on your desktop, open* gconf-editor and navigate to Apps → Nautilus → Preferences:

  • There, disable show_desktop and start xplanet normally. It should now be on your desktop.

I've gone through all this, and it seems to work fine. But, as I said, only without desktop effects (but maybe that's just me).


*: to open an application, you can either hit Alt+F2, and type the command there or you can open a Terminal via Applications → Accessories → Terminal.

share|improve this answer
    
Wow, thanks a lot for this detailed explanation. I'm seeing the image on my desktop now. What do I miss when I disable the desktop effects? I don't really care much about eyecandy, so I think I won't notice the differences anyway. –  cringe Dec 5 '10 at 21:37
    
Do you have them enabled at the moment and see the image on your desktop? –  Stefano Palazzo Dec 5 '10 at 23:41

You might want to read this forum post.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.