Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Have young kids that manage to foul up Ubuntu by playing with the universal access options at the login screen. Tried following the directions for 10.04 but the stated directories don't exist in 12.04 How can I completely remove the Universal Access options from the login screen from Ubuntu 12.04?

share|improve this question
    
The default settings file (located at: /usr/share/doc/lightdm/lightdm.conf.gz) does not appear to have any settings related to Universal Access. Nor does the command line tool (by running: /usr/lib/lightdm/lightdm-set-defaults --help). –  david6 Jul 14 '12 at 0:42

2 Answers 2

Unfortunately, the accessibility option in the login menu bar is hard-coded into the unity-greeter source code, and short of modifying that, there appears to be no way to remove it (like a number of other Unity UI features...)

Your best bet is to simply make the icon invisible. While it will still be there, it won't show and hopefully your children will be fooled :)

  • The icon is provided by the file /usr/share/unity-greeter/a11y.svg
  • Here's the pastebin of an appropriate blank icon.
  • To replace yours, open a terminal and:

    cd /usr/share/unity-greeter
    sudo mv a11y.svg _a11y_backup.svg
    sudo wget -Oa11y.svg http://pastebin.com/raw.php?i=h2dRGH4K
    

Result of clicking the "invisible" icon:

enter image description here

share|improve this answer
    
That worked. The icon is "hidden". We'll see if that is sufficient to keep the little ones from destroying the usefulness of Ubuntu 12.04... –  Charles Hartman Jul 16 '12 at 4:53
    
@CharlesHartman: glad to know, hope it works out too. Please consider accepting the answer (tick/check mark on the left) in that case, so that the question is closed and people know this "hack" works. –  izx Jul 16 '12 at 4:56
    
Having spent some time looking at the greeter source code over the past month, I think this is the cleanest solution short of a recompile. –  mfisch Jul 26 '12 at 2:47

I have implemented solution from 11.10 and it works for me :)

askubuntu.com/questions/113514/how-can-i-remove-icons-from-the-gnome-shell-panel

Yo open mentioned file with owner privileges I used command in terminal:

gksudo gnome-open /usr/share/gnome-shell/js/ui/panel.js
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.