Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, 12.04 x86_64 is installed and working properly. I see grub and plymouth, then lightdm, X session for Unity is good. My framebuffer resolution for TTY1-6 is 1280x1024. X is 1680x1050.

I can use fbset to manually change the fb resolution to the desired 1280x800. Then to make it stick for all future settings, I changed the resolution in /etc/default/grub and /etc/initramfs-tools/modules. I then ran update-grub2 and update-initramfs -u, rebooted, but it is still in 1280x1024.

Where am I going wrong?

System 12.04 (x86_64) NVIDIA Driver Version: 295.49 fb0 modes:

U:1280x800p-60 U:640x480p-67 V:1280x1024p-75 V:1280x1024p-60 V:1024x768p-75 V:1024x768p-70 V:1024x768p-60 V:800x600p-75 V:800x600p-72 V:800x600p-60 V:800x600p-56 V:640x480p-72 V:640x480p-60 U:1280x800p-60 U:320x240p-60 U:320x400p-59 U:320x200p-59 U:1280x1024p-59 U:1024x768p-60 U:800x600p-59 U:640x480p-60 U:640x400p-59

share|improve this question

1 Answer 1

up vote 1 down vote accepted

So I missed a very obvious nomodeset in my /etc/default/grub file. I changed that to modeset. Now I have a better looking terminal.

Correct framebuffer settings for native FB resolution for my NV 550 Ti.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modeset video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.