Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.04 Server with lxde installed onto it. My computer is a HP Pavilion ze2000 which happens to have the broadcom wireless card.

[Output]: lspci -nn | grep 14e4

05:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

I was eventually able to get the wireless connection working but it does not persist after rebooting. With ethernet cable unplugged:

  • If I do sudo ifconfig wlan0 up then do sudo /etc/init.d/networking restart it freezes and eventually does not start the network (in this case it seems to be doing the same thing it does during boot).

  • However, if I do sudo ifconfig wlan0 up, then plug in the ethernet cable, then do sudo /etc/init.d/networking restart it fires right up and connects to the wireless. In that latter case, it connects to the wireless even though the ethernet cable is still plugged in. Then I can unplug the enthernet cable and still be connected wirelessly (unless I reboot). It looks like all the same modules are loaded both before and after.

Does anyone have some clues where to look for the problem?

share|improve this question

2 Answers 2

Change manage=true in your /etc/NetworkManager/NetworkManager.conf file if it is manage=false

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

no-auto-default=08:00:27:9A:D4:9A,

[ifupdown]
managed=true
share|improve this answer

Thanks msPeachy. I did try that but to no avail. This got me back into solving the issue though (I'd sort of given up for a while). I don't recall what it was now but I noticed something in the messages printed during boot and did a google search which lead me to this here: http://ubuntuforums.org/showthread.php?t=2048447 I did what was suggested in that thread and my computer is now able to boot and connect to my wireless connection just fine.

Specifically, this is what solved the issue for me:

Changed /etc/NetworkManager/NetworkManager.conf back so the line reads "managed=false" (without quotes).

Followed what is given in the post linked above with one tiny modification...

For me, "sudo service networking restart" would not work - so I did a

sudo /etc/init.d/networking restart

instead. Everything else I did exactly as given in the forum thread.

Here is what my /etc/network/interfaces file looks like right now:

# This file describes the network interfaces available on your system
#and how to activate them. For more information, see interfaces(5).
# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
#auto eth0
#iface eth0 inet dhcp
/etc/network/interfaces (END)

See how the last three lines are commented out - just like it said to do in the thread?

I rebooted the computer without the ethernet cable and it booted and connected to my wireless network. I'm going to completely delete those commented lines from the /etc/network/interfaces file next.

share|improve this answer
    
Good work. Please consider accepting your answer to mark this as solved and to remove it from unanswered queue. –  Peachy Sep 24 '12 at 5:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.