Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted yesterday regarding how to configure easytether on Ubuntu. I followed the steps and everything looks good from the terminal. But I am not able to connect to the Internet. Currently I am connected to a Wireless network, I tried disconnecting to it, in hope to connect to Internet using my phone but with no help. How do I make my notebook use my cell phone's connection. I have attached the snapshot from the terminal.

alt text

share|improve this question
    
Have you tried setting up your phone in the usual way? (That is, did it show up in network-manager after you've plugged it in for the first time?) If so, have you encountered any specific errors there? –  Stefano Palazzo Dec 6 '10 at 23:05
    
What kind of phone is this and what version of Android do you have ? –  MagicFab Dec 15 '10 at 2:57

4 Answers 4

up vote 2 down vote accepted

To use any DataCards on Ubuntu for Internet

sudo apt-get install wvdial

  • run these:

  • lsusb

  • modprobe

  • wvdial

  • modprobe usbserial vendor =0x0eab product =0×9357 (check the output of lsusb for it)

  • open editor for the file /etc/wvdial.conf (you can run the command gksu gedit /etc/wvdial.conf in a terminal) and enter the following lines and save:

[Dialer Defaults]

Init1 = ATZ

Init2 = ATE0V1

Modem Type = Analog Modem

Baud = 115200

New PPPD = yes

Modem = /dev/ttyUSB0

ISDN = 0

Stupid Mode = 1

Phone = #777 // this is for dialing e.g for reliance

Password =

Username =

To avoid modprobe everytime system boots write a simple script i.e on a simple text file and save it with the name modprobe-1.sh , make it executable by running chmod +x modprobe-s.sh and save this file in /usr/bin or in /bin after that just run modeprobe-1 ( it will work like custom command).

#! /bin/bash

echo pwd | sudo -S modprobe usbserial vendor =0x0eab product =0×9357

echo pwd | sudo -S wvdial

(where pwd is your sudo password)

share|improve this answer

I checked this link and this one, a bit shorter and using easytether. it seems that everything you are doing is correct. Have you actually done what you need to do on your phone? i.e. gone into wireless settings and allow share network, etc.? You might need to look up if there is an extra setting with your model.

share|improve this answer

Yes this we have implemented with USB based Data Card

on ubuntu as well as on RHEL, Are you looking for internet sharing then you have to

do use iptables and search for ip masquerading and internet sharing

share|improve this answer

Usually, if you have an Android phone that has version 2.2(i think) or Android 2.3, there should be an option under Wireless & Networks..there should be a an option of tethering through USB. I hope that helps you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.