Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometime ago, I installed S3TC packages via PPA to get the most updated package version. But now I want to uninstall it and get back the "standard" Ubuntu package version. When I tried to remove it via Synaptic, it returned various other dependent packages that will be remove with the uninstallation. How can i uninstall just this package?

share|improve this question
    
What else have you tried? –  Mitch Jul 13 '12 at 17:06
    
I tried forcing version on package > force version on Synaptic. But it didn't change anything. –  hfa2010 Jul 13 '12 at 17:19

1 Answer 1

up vote 1 down vote accepted

Have you tried sudo apt-get remove s3tc? If it remove following package then remove that ppa that you added for this particular software. I think its a piece of graphics card software. What graphic card you are using?

share|improve this answer
    
See Here. It could help. –  Kaktarua Jul 13 '12 at 17:34
    
Intel HD 3000. Actually i sorry because maybe i've omitted some things. The thing is that i used to have xorg-edgers here already installed it, but the libgl dri packages are still from ppa's. I'm trying to undo this change because the game Amnesia here has been having some problems apparently with the drivers( graphics blinking, failing) and searching in Synaptic i realized that i said here the wrong name... Isn't S3TC properly but the mesa-dri packages, but the situation is still the same. –  hfa2010 Jul 13 '12 at 17:34
    
Select origin from synaptic package manager. Find out your PPA and remove what is causing problem. After that. Remove that ppa from Source. And do a sudo apt-get update && sudo apt-get upgrade. Let me know. –  Kaktarua Jul 13 '12 at 17:45
    
i just used the ppa you post first(i choose it because of the updated graphics whithout the experimental packages as in xorg-edgers) and solved some broken packages(nouveau) now it seems fine. –  hfa2010 Jul 13 '12 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.