Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Out of the blue, my eclipse is reporting missing jars in my Java Build Path.

netx.jar
gnome-java-bridge.jar
plugin.jar

I wonder what I did wrong ? Was it a upgrade that messed it up ?

I am unable remove those jar's from my the list aswell (that is probably because my eclipse is not running as super user).

Just running as super user, removing those missing jar's may not be the solution. Any advice ?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

I had the same problem after an upgrade i was missing the gnome-java-bridge.jar in my open-1.6-jdk

I changed all my projects to the 1.7 openjdk. since everthing is working as it should!

share|improve this answer
    
Ok, I see it now. Thanks.. I'll change to 1.7 and report back. –  Siddharth Jul 13 '12 at 12:31
    
Although moving to 1.7 is not the right solution as for many people who read this q&a, they may need to do a full round of testing for a new JDK. I recommend trying what Rick recommended, or my magic (answered below). –  Siddharth Jul 19 '12 at 18:12

I also had the exact same problem as Jerry. Missing my gnome-java-bridge.jar. However, you don't have to load the new jdk. Just reselect the jre and Eclipse will reload the library list from the jre and everything works as expected

Window->Preferences->Java->Installed JREs

You might have to edit your Runtime for your Server settings (I did).

share|improve this answer

I have solved the problem without installing the jdk 1.7. The problem was due to the value 1.5 set in the field "Compiler Compliance level" at Window->Preferences->Java->Compiler.

Having jdk 1.6 and changing the value to 1.6, the problem was solved.

Cheers, Eric.

share|improve this answer

Forgot to update the solution.

I installed JDK 1.7, created my eclipse setup to work with 1.7, and magically 1.6 too works now. May be I should have tried what Rick did. I will next time around.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.