Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 12.04 LTS, fully up-to-date. I'm new to Ubuntu. Whenever I start my system I face "System Program Problem Detected." Why is this happening? I ran sudo rm /var/crash/* but it again appears after some time. What could be at fault?

share|improve this question
By fully-updated, its 12.04.2, right? 'coz there are a lot of bug fixes in 12.04.2. – i08in Feb 25 '13 at 11:29
stop the still-running apport service:sudo stop apport after deleting crash and doing @Ian's answer. – Afshin Hamedi Sep 22 '14 at 10:30
I read your question and sudo rm /var/crash/* solved my problem. The problem started to happen after I could not wake up my laptop from hibernate and did a cold reboot. – atmelino Apr 30 '15 at 1:37

I am using Ubuntu 14.04 right now and faced the problem. It helped me. System Program Problem Detected

sudo sed -i 's/enabled=1/enabled=0/g' /etc/default/apport
share|improve this answer
That's what @Ian posted. – Avinash Raj May 1 '14 at 4:28

You need to disable apport.

To do so, follow these steps:

  • Hit Alt+F2 and type gksu gedit /etc/default/apport.
  • Open the file and change the value of enabled from 1 to 0.
  • Save and exit. Reboot.


share|improve this answer
Welcome to Ask Ubuntu. While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Peachy Sep 24 '12 at 5:35
disabling doesn't solve this. – Dr_Bunsen Feb 27 '13 at 11:03
Simply disabling apport doesn't solve the problem. It's just a workaround and potentially harmful one. – int_ua Nov 8 '13 at 10:28
@Dr_Bunsen: Although about two years and three months later, would you like to say how to actually solve this problem or at least mention the problem's source? Additionally, in Ubuntu 15.04? – ashubuntu May 19 '15 at 12:12

Open your terminal and type:

gksudo gedit /etc/default/apport

And hit Enter. Change the text "enabled=1" to "enabled-0". Then, save and exit.

To solve this problem, you can watch this YouTube video.

share|improve this answer
You should add the steps required to solve the problem. Then you can mention the source. – green Apr 14 '13 at 12:07
steps are in the video – Ziyaddin Sadigov Apr 15 '13 at 8:34
Atleast write a summary of steps. – green Apr 15 '13 at 10:01
ok, wrote a summary – Ziyaddin Sadigov Apr 17 '13 at 12:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.