Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used Wubi to download 12.04 on a new partition. When restarting, the computer (Levono windows 7 -64) froze with no signal on my screen. Turning the computer on and off I received the option to sign in on windows or ubuntu. Windows worked well, but Ubuntu seems to bomb again as before. I can look at the new partition where some Ubuntu files exist via Windows explorer. What am I to do? Is 12.04 compatible with windows 7?

share|improve this question
add comment

2 Answers 2

By default, Wubi does not install on a different partition. It creates a virtual "hard disk" file within your primary storage drive (typically C:), from which it runs Ubuntu.

If you intentionally instructed it to create this disk on a separate partition of your drive, it could be that Windows is having issues interacting with it. Can you access that partition's letter from Windows (specifically, the Wubi directory, which is X:/ubuntu, where X is the respective drive letter)?

If you simply mistook the function of the Wubi installer, then I'm not quite certain. It could be a corrupted .iso file, or perhaps an incompatible one (I'm not sure if a 64-bit Ubuntu .iso can be installed over a 32-bit Windows system, for example). It could also be that, for whatever reason, Wubi didn't install the grub2 bootloader (the bootloader which appears after you select Ubuntu after boot) correctly.

If I were you, I'd just uninstall Ubuntu through the Control Panel or by running Wubi again (it should prompt you to uninstall), and reinstall it, making sure it is on the same partition as your Windows installation.

edit - It could also be that your hard drive is overly fragmented (though this is unlikely). If none of the above solutions work, running the Windows defrag tool after installation might help.

share|improve this answer
    
I intentionally instructed Wubi to create the disk on a separate partition. I can access the partition's letter from Windows. I have a 64-bit windows system. I did uninstall and reinstalled Wubi again. Since it offered me where to install it, it should not give me this problem on account using a different partition. I want to ensure my windows C: partition stays large enough for future work. Can I specify this in Wubi? –  August Guillaume Jul 16 '12 at 22:05
add comment

This is the standard "black-screen-on-boot" that regular Ubuntu users with Nvidia/AMD graphics often have.

You need to do the following from within Windows:

Edit file C:\ubuntu\install\wubildr-disk.cfg

It should look like:

loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
search --set=diskroot -f -n /ubuntu/disks/root.disk
probe --set=diskuuid -u $diskroot
linux /vmlinuz root=UUID=$diskuuid loop=/ubuntu/disks/root.disk preseed/file=/ubuntu/install/preseed.cfg wubi-diskimage ro quiet splash
initrd /initrd.img
boot

Edit the long boldedlinux /vmlinuz ... line to add nomodeset at the end. I would also recommend removing quiet splash until your WUBI is working just right. So the end-should look like .... wubi-diskimage ro nomodeset.

Save, reboot into Wubi-buntu.

Then go to Settings...Additional Drivers, and install the appropriate Nvidia/AMD driver. Once that's done, you can go back to Windows and edit the file again, removing nomodeset.

share|improve this answer
    
The file looks exactly what as above. The location is the drive I want to use for Ubunto (e:). However the "black-screen-on-boot" stays on rebooting to Ubuntu. –  August Guillaume Jul 16 '12 at 21:58
    
I downloaded the ubuntu 12.04 32 bit iso, and after a few tries it worked. Someone should review wubi with levono computers –  August Guillaume Jul 20 '12 at 2:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.