Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I am trying to install matlab (R2010b) and I can't get the installer to appear. This is how far I get:

ivana@ivana-desktop:/usr/local/matlabR2010b$ sudo ./install -v -glnx86
Preparing installation files ...
->  DVD                 = /usr/local/matlabR2010b
->  ARCH                = glnx86
->  DISPLAY             = :0
->  TESTONLY            = 0
->  JRE_LOC             = /tmp/mathworks_21291/java/jre/glnx86/jre
->  LD_LIBRARY_PATH     = /usr/local/matlabR2010b/bin/glnx86

Command to run:
/tmp/mathworks_21291/java/jre/glnx86/jre/bin/java  -Djava.ext.dirs=/tmp/mathworks_21291/java/jre/glnx86/jre/lib/ext:/tmp/mathworks_21291/java/jar:/tmp/mathworks_21291/java/jarext -jar /tmp/mathworks_21291/java/jar/installwizard.jar -root /usr/local/matlabR2010b 

Installing ...

So everything looks very nice, except that after that nothing happens! No Installer pops up or whatsoever. I thought it might be somehow related to the problem similar to this one, but it doesn't seem so:

ivana@ivana-desktop:/usr/local/matlabR2010b$ ls -l java/jre/glnx86/jre/bin/java
-r-xr-xr-x 1 root root 47308 Jan 27  2010 java/jre/glnx86/jre/bin/java

Some things I tried and didn't work: running gksu ./install and installing sun jdk 7.

I haven't seen anyone encountering the similar problem, so I would really appreciate any suggestion that would point out to what might be wrong.

share|improve this question
I think it did install, because it says Installing.... did you try to run matlab? – Thomas Ward Jul 12 '12 at 18:43
I tried, but there is no matlab. And Installing... was there only for a couple of seconds – ivana Jul 12 '12 at 18:47

There is one point which surprises me: You seem to have mounted the MATLAB DVD image in /usr/local/matlabR2010b (or you have copied the files there). This is an unusual place to mount a DVD image. More importantly, it is the same directory where MATLAB should be installed (see the -root argument at the end of the command to run). I can’t verify it right know, but it could be that the installer doesn't do anything because of that reason.

If mounting the DVD image at some other location does not help, some ideas for further analysis of the problem: It is quite obvious from the source of the installation script that the only thing which can fail without showing a real error is the command stated as “command to run”. Therefore, you could try to run that command manually and adding the -verbose argument. However, the installation script creates some temporary files you will need beforehand. The easiest way to get these is probably commenting line 567 of the script:

rm -rf $TEMP_DIR

Then you execute it once and can afterwards execute the actual installation command with the -verbose flag.

share|improve this answer

I know this may not sound very useful seeing as it doesn't answer your question, however I've found that on Ubuntu GNU Octave combined with the QtOctave UI (both downloadable from Ubuntu Software Centre) work well to give you an alternative (slightly different UI but identical syntax) if you don't manage to get Matlab working and you really need to get some things done it's quite nice, my laptop crashed a while back and I was really glad I'd had this as a quick option.

Edit: Forgot to mention, creates identical files to Matlab, so any compatibility issues are pretty much non-existent.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.