Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a SD-card reader on my laptop and I am currently working on my phone. So I need to transfer several times from / to my SD card. The problem is that, when I insert my SD-card in the reader, it gets automatically mounted and Nautilus opens. So I transfer my files and then remove the card. After removing it, I just can't get it to mount again.

I insert it and nothing opens. Tried to mount via terminal, but just can't open it in Nautilus again. After restart, it automatically opens like before but again just only one time. What can I do? I have restarted my laptop about 15 times today.

share|improve this question
    
About the P.S. part , no it won't affect your Laptop in any way . but if you say 15 times, then charge will run off fast i guess. –  tijybba Jul 12 '12 at 18:17
add comment

1 Answer

On my system (does not have a built-in card reader), I have a multi-card reader which shows several "drives", such as SD, SM, CF, etc with no devices plugged in. When I plug in an SD card, the SD card mounts and its name shows up after the "drive".

If I eject the SD card, or simply remove it, then next time I insert it, it will auto-mount. But if I select the SD card, and choose "Safely remove Drive" from the right-click context menu, then the entire reader unmounts, and I can't simply insert the SD card to read it - I need to unplug the reader, and plug it back in.

I realize this may not be a normal answer, depending on whether you have an internal or external reader, and whether you choose the "Safely remove drive" option or not, but if you do choose this method, you might try simply "eject" or just removing the card.

If you already simply remove the card, you might try using "eject" to see if that makes a difference in your case.

share|improve this answer
    
Actually mine is internal reader. And I'm always just getting it out. Tried to eject it , the same. Plus that not it has been turned into read-only file system :X But works well on my W7 ... Whatever , will use my second laptop for now since i find solution (what im doing now really needs much mounting unmounting...) –  Vency Jul 12 '12 at 19:20
    
I push my sd card into my android cell phone when I go to gallery or try to take a photo it say your sd card is not mounted or secure what do I do to correct the problem? –  user84140 Aug 18 '12 at 15:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.