Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Dell Inspiron 17R that I have installed ubuntu 12.04 on. The touchpad is recognized as a PS/2 mouse, which means that I can't use scrolling and that there is no "Touchpad" tab in the mouse settings.

How can I fix this? I've searched for the answer, but there's very little information about 12.04, and people keep mentioning this .deb package that I am supposed to download from http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb, which is a dead link.

share|improve this question
    
by the way, can you use an external mouse? –  alfC Oct 19 '12 at 11:49
    
Yes. Any USB mouse I've tried works perfectly, including scrolling and back/forward buttons. –  Kalle Elmér Oct 19 '12 at 13:22
    
Ok, for some reason my usb wireless doesnt work (works well in other computers) but a wired mouse works. I though the problems were related. Still no luck with scrolling. –  alfC Oct 19 '12 at 17:19
add comment

5 Answers

up vote 1 down vote accepted

Please take a look at this thread

Support for Inspiron 17R SE is getting closer thanks to Dave Turvene's work. Scrolling already works for me, two-finger support still missing, but it is a work in progress making headway.

share|improve this answer
1  
Support for this touchpad is ready. Download information here: bugs.launchpad.net/ubuntu/+source/linux/+bug/606238/comments/… –  Vreixo Sep 28 '12 at 23:57
    
I'm using this driver now (version 0.4). It works great and I even get multitouch! –  Kalle Elmér Oct 13 '12 at 12:00
    
As usual, it is hard to figure out what to do with these scripts. Sorry for the negative note. –  alfC Oct 19 '12 at 10:12
add comment

I was able to find a workaround that's almost good enough to be called a solution. It is possible to emulate a scroll wheel while holding down both the left and the right mouse button. They have to pressed simultaneously, but this should be easy enough on a laptop that allows you to press both of them with a single finger. Follow these steps to make it work.

  1. Open a terminal (Ctrl-Alt-T) and type "sudo apt-get install gpointing-device-settings". Enter your password when asked. gpointing-device-settingsInstall gpointing-device-settings
  2. There should be a new utility called "Pointing devices". Since I use Gnome Classic, it's located under Applications -> System Tools -> Preferences, but you should be able to search for it in Unity.
  3. Select "Use middle button emulation" and select a short timeout, unless your laptop already has three buttons. This will trigger the "middle button" whenever you press both buttons at once.
  4. Select "Use wheel emulation" as well as vertical/horizontal scrolling to your liking.
  5. Select button 3. This tells the system to use the "middle button" you just created for scrolling.
  6. Adjust the timeout and inertia sliders for wheel emulation to the settings you find optimal.

If it takes to long for the "scrolling mode" to activate, you need to reduce the timeout. On the other hand, if scrolling is activated instead of middle clicking, you need to increase it. Select a value that suits you. I keep this one slightly to the left of the middle.

The inertia slider adjusts the scrolling speed. The more inertia, the slower your scrolling will be. For me, this slider is very close to the left end, and has to be adjusted very carefully.

That's it. Whenever you hold down both buttons, you should be able to scroll using the touchpad. As an added bonus you will get the middle button, which is good for a lot of things such as pasting text in the terminal and opening websites in new tabs.

share|improve this answer
    
Kalle, apologies for an off-topic question, but can you share how you setup the nvidia 650m video card in your laptop? Did you use bumbleebee? How is the fan noise/heat emissions under linux? –  user77199 Jul 15 '12 at 17:51
    
I haven't really done anything about the graphics card. For now I'm not gaming so I don't know about performance, but compiz seems happy and the desktop effects are just fine. I don't find the fan noise to be bad at all. I think the battery life is almost two hours with maximum screen brightness and all settings as default. My laptop is called "Special Edition" (N7220) and uses more power for CPU and GPU. I did notice that ubuntu doesn't automatically suggest a proprietary driver for the graphics card, which should mean that I will need to do something about it to get full performance. –  Kalle Elmér Jul 15 '12 at 22:36
add comment

I have the same problem, unfortunately there is still no support for that touchpad in Linux.I've found this bug-report thread interesting to read.

Otherwise the bug for Ubuntu is reported here.

Although this bug involves a lot of different devices some of them are supported in recent kernels.

EDIT: Support for this touchpad is now already done. Download the information about it here.

share|improve this answer
    
Well, at least that's the only problem I'm having at the moment. Perhaps there is some piece of software that can provide a useful scroll function? I was thinking something like holding a specific key or pressing both the right and left buttons at the same time. This would turn all mouse movements into scrolling, and it should work with a generic mouse. –  Kalle Elmér Jul 13 '12 at 15:36
    
The link in your edit only points to a comment, how do I apply it to Ubuntu 12.10? –  alfC Oct 21 '12 at 6:45
add comment

To set up the Nvidia 650m just run from console:

sudo apt-get update
sudo apt-get install nvidia-current

nvidia-currentInstall nvidia-current

That should download the latest release.

I am also troubled by the lack of touchpad. I am just dark that I did not research the manufacturing company of the touchpad in new Dell machines.

We would expect however at some stage the psmouse kernel module will be updated for these new devices once open source can reverse engineer the multitouch instructions.

share|improve this answer
    
I've been looking at this a bit more, and there would seem to be a lot of work in progress. I believe it will be reverse-engineered at some point in the future. –  Kalle Elmér Aug 12 '12 at 12:58
add comment

I managed to get my touchpad working with two finger scrolling. It is also not so annoying when typing - although not completely disabled. Fn + F3 now disables/enables the touchpad where this didn't work before.

I used the info as put together here Geek-Tips Ubuntu 13.04 on Inspiron 17R

See point 2.

Copying from there:

1) Start by downloading the latest source code package from http://www.dahetral.com/public-download

2)

sudo apt-get install dkms
tar -xf psmouse-alps-X.X.tbz
sudo mv usr/src/psmouse-alps-X.X/ /usr/src/psmouse-alps-X.X/
sudo dkms add psmouse/alps-X.X
sudo dkms autoinstall
sudo rmmod psmouse && sudo modprobe psmouse
share|improve this answer
    
I get "Error! Build of psmouse.ko failed for: Consult the make.log in the build directory /var/lib/dkms/psmouse/alps-1.3/build/", and then make.log shows no errors. What could it be? –  alfC Jan 8 at 3:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.