Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Skype contact list, Home folder, etc. How to open them in foreground?

share|improve this question
    
Do these windows always open behind other windows, for you? –  Eliah Kagan Aug 22 '12 at 8:14
    
It happens from time to time –  Alexey Plutakhin Oct 3 '12 at 11:34
    
Same here with e.g. Skype. It seems to be application dependent: Happens always with Skype, but never with e.g. LibreOffice. So either an application falls into the "background category" (then it is always reproducable) or not (then it always works fine). –  Izzy Oct 9 '12 at 14:58
    
Btw: for those who think it rarely happens, I just found this thread on UbuntuForums talking about it in detail. Unfortunately without finding a solution -- but exactly the same software affected: Skype, Home folder, plus Tomboy. –  Izzy Oct 9 '12 at 15:22
add comment

1 Answer 1

Me too I suffered from app window shyness. I found how to fix it, though.

  1. get compizconfig-settings-manager

  2. Press Alt+F2 and type ccsm

  3. click on "General Options"

  4. Select the "Focus and Raise Behaviour" tab

  5. Check "Auto-raise" and set "Focus Prevention" level to Off

That fixed things up for me. Hope it does for you as well.

share|improve this answer
    
This didn't fix it for me. For example Transmission, or KMahjongg always open behind any other open window. I'm using Unity-2D with 12.04LTS. –  mivk Oct 23 '13 at 10:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.