Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am setting up Cisco VPN on Ubuntu 12.04, when I run into strange behavior. I have downloaded and installed the following packages: vpnc network-manager-vpnc and dependencies.

When adding the connection with network manager, I am not able to save the connection - I only get this error

VPN error

I have tried different settings, tried importing cisco .pcf without any luck so far.

Errors

While searching for solutions, I have stumbled upon a way to restart the network manager applet:

killall nm-applet; nm-applet &

This did not solve my problems, but I noticed that a log is written to the terminal after running the command, and I think it may tell something (no idea what, though!)

After clicking save, these lines are written in the terminal:

(nm-applet:4079): GLib-GIO-CRITICAL **: g_async_initable_real_init_finish: assertion `g_simple_async_result_is_valid (res, G_OBJECT (initable), g_async_initable_real_init_async)' failed

** (nm-applet:4079): CRITICAL **: dbus_g_error_has_name: assertion `error != NULL' failed

(nm-applet:4079): GLib-CRITICAL **: g_error_free: assertion `error != NULL' failed

(nm-connection-editor:4157): GLib-GIO-CRITICAL **: g_async_initable_real_init_finish: assertion `g_simple_async_result_is_valid (res, G_OBJECT (initable), g_async_initable_real_init_async)' failed
share|improve this question
add comment

2 Answers 2

Useful suggestions here Config import on network-manager-openvpn which helped me to establish that my problem (same symptoms as above) are down to the network manager and not openvpn itself.

share|improve this answer
add comment

Had the same problem & just fixed it. I've installed gnome3 using ricotz's ppa. Before I had some problems with gnome-shell-extensions so I've downgraded it to gnome3-team ppa packages (maybe it takes a part). To fix nm problem I've downgraded libglib2.0-0 from ricotz's version to precise-updates. I've made this by synaptic (package->force version), but I think cli version is

sudo apt-get install libglib2.0-0/precise-updates
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.