Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using ubuntu 12.04. I had installed ffmpeg a while ago (so don't clearly remember whether it was from source or repo). Now, I am unable to uninstall it. I have tried the followin:

$ sudo apt-get remove ffmpeg

$ sudo apt-get purge ffmpeg

I tried to find ffmpeg directory by issuing the following command:

$ find / -name 'ffmpeg' -type d

This gave me /home//ffmpeg. When I changed to the directory, I found ffmpeg and ffmpeg1, however "sudo make uninstall" didn't work for both the places and threw an error "make: * No rule to make target `uninstall'. Stop.". That, I suppose, would mean that it was not the source from which ffmpeg was (if) compiled.

When I issue the following command:

$ffmpeg -version

I get:

ffmpeg version 0.8.3-4:0.8.3-0ubuntu0.12.04.1, Copyright (c) 2000-2012 the Libav developers
  built on Jun 12 2012 16:37:58 with gcc 4.6.3
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
ffmpeg 0.8.3-4:0.8.3-0ubuntu0.12.04.1
libavutil    51. 22. 1 / 51. 22. 1
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 0 / 53. 21. 0
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0
share|improve this question
Someone will probably post a one-line command that will fix it for you, but you might try using Synaptic and mark ffmpeg for 'complete removal'. This usually works pretty well for removing programs. – Tom Brossman Jul 12 '12 at 9:40
@TomBrossman: Thanks for the help ! I shall try your suggestion and shall update the result here. – gentrobot Jul 12 '12 at 9:42
@TomBrossman: In the Synaptics Manager, when I searched for "ffmpeg", the installed packages that appear are: chromium-codecs-ffmpeg-extra, librtmp0, winff, gstreamer0.10-ffmpeg. Should I remove them all ? – gentrobot Jul 12 '12 at 9:49
No Idea. It isn't going to break your system so try it. If you have audio playback issues just re-add them. – Tom Brossman Jul 12 '12 at 9:52
up vote 11 down vote accepted

For reasons discussed in this question, the "ffmpeg" in Ubuntu 12.04 is actually provided by the libav-tools package; that's why removing the ffmpeg package seemingly does nothing.

To really remove it:

sudo apt-get --purge remove libav-tools
sudo apt-get --purge autoremove

Note: The contents of the 2.2 kB ffmpeg package deb file as provided by libav simply pulls in libav as dependencies...

share|improve this answer
Thanks ! That worked. And +1 for the link that made me understand more about Ubuntu 12.04's ffmpeg – gentrobot Jul 12 '12 at 10:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.