Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If i type lspci| grep VGA into the terminal i get this output:

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller(rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd1 (rev a1)

When i install nvidia-current it installs 259.49 which is the wrong driver for the 650m (259.59 is the correct). Any thoughts?

EDIT: I employed this command dpkg --list | egrep '(nvidia|bumbl)' | grep ^ii which output

ii  bumblebee                              3.0-2~preciseppa1                       nVidia Optimus support
ii  bumblebee-nvidia                       3.0-2~preciseppa1                       nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-common                          1:0.2.44                                Find obsolete NVIDIA drivers
ii  nvidia-current                         295.40-0ubuntu1                         NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                        295.33-0ubuntu1                         Tool of configuring the NVIDIA graphics driver

So I guess this shows that since it has no idea which card it is, it doesn't pick the right drivers...

Also the computer is a Samsung Series 7 (700Z7C) if that helps

Running optirun glxspheres gives this output in kern.log

NVRM: GPU at 0000:01:00.0 has fallen off the bus.
NVRM: GPU at 0000:01:00.0 has fallen off the bus.
NVRM: RmInitAdapter failed! (0x26:0xffffffff:1170)
NVRM: rm_init_adapter(0) failed
share|improve this question
    
is it laptop? do you have nvidia optimus technology? –  Web-E Jul 12 '12 at 4:38
    
yes it is a laptop, with nvidia optimus –  twf0001 Jul 13 '12 at 0:23
    
possible duplicate of How well do laptops with Nvidia Optimus work? –  Jorge Castro Jul 17 '12 at 16:50

4 Answers 4

up vote 12 down vote accepted

Ok, as you haven't mentioned in your question that you have optimus enabled laptop and as per the interaction with other users it is clear that you are into a mess. A fresh install is required, Let me explain it to you.

optimus isn't supported by nvdia drivers in linux. So if you install nvidia drivers from any repo. You won't be able to boot into GUI. The linux driver page of nvidia has a warning like The driver won't work with few models (few means optimus enabled graphics cards)

So there is some unofficial work to get the power save feature at least (i.e. to turn off the discrete GPU). The first success was by mj-casalogic.(I don't know his name) His first project named as bumblebee then he updated it and renamed it ironhide.

However ironhide wasn't well designed and it has lot of problems. It is now abandoned project.

Bumblebee 3.0 was a fork of original bumblebee project. It has more stability and whole code was re written a C. Now a daemon runs from the startup. Disable the discrete GPU automatically and use it only when required. But this is not compatible with ironhide or earlier bumblebee. You have to do a lot of things to get this working. Its easier to reinstall ubuntu.

After clean installation of ubuntu, do the following

Instruction for installing Bumblebee to turn off discrete GPU and enable only when required

  1. Type the following in terminal,

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

  2. To install Bumblebee using the proprietary nvidia driver:

    for 12.04 - 13.04

    sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic

    And for 13.10 :

    sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

  3. Reboot.


If you just want to disable nvidia card, no need to learn followings

Usage Instruction :

To run a program with nvidia card, use optirun command prefixed in terminal. Like to run glxspheres with nvidia card type

optirun glxspheres

To run firefox type : optirun firefox &


To get the graphics card model, install mesa-utils Install mesa-utils.Remember the graphics card model won't be nvidia one. It will be intel, because in nvidia optimus the nvidia card isn't exposed directly. Nvidia card is wired via the intel one

Linked Questions:

How well will Nvidia Optimus cards be supported in 12.04?

How well do laptops with Nvidia Optimus work?

Can't use nvidia card/driver on optimus notebook

share|improve this answer
    
Did a fresh install, entered the commands, ran optirun glxspheres got this:[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please [ERROR]Aborting because fallback start is disabled. –  twf0001 Jul 14 '12 at 23:08
    
My feeling is that since Ubuntu does not know which model it is how can it know what drivers to install (unless I am not understanding the concept right). I know it is a 650M since I bought it but Ubuntu does not show that anywhere. –  twf0001 Jul 14 '12 at 23:16
    
ubuntu does. See output of lspci | grep VGA. The 650m is having problem with bumblebee as Sepero posted it. The drivers is released very recently. It will take few more days to come in the repo. driver link. 295.53 doesn't support your product, 295.59 does. Please wait for few days. And you are missing a point Nvidia 650m won't be listed as your graphics card in System info. Because intel is connected to laptop display, nvidia is connected to intel. nvidia isn't exposed to display manager. –  Web-E Jul 15 '12 at 4:31
    
To change graphics card from unknown to intel you need the package that I posted. –  Web-E Jul 15 '12 at 4:35
    
Correct me if am mistaken (i posted output of lspci | grep VGA in original post) shouldn't it say NVIDIA Corporation Device [GeForce 650M] not 0fd1? I guess this is where i am thinking that my computer isnt recognizing my card. –  twf0001 Jul 15 '12 at 5:49

I got Bumblebee working. I am using Mint 13 64bit Mate Maya which is pretty close to Ubuntu 12.04, on Samsung Series 7 Chronos NP700z5c Optimus laptop using Intel Ivy Bridge hd4000 Intel GPU, and Geforce gt 630m GPU and using i7-3615QM CPU.

This site helped a lot: http://www.noobslab.com/2012/06/nvidia-drivers-collection-for.html

Do all the step there except step #7 and then you will have to do the following in a terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Now add following lines to the end of the file and save:

blacklist amd76x_edac
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

You will need to do the following in a terminal:

sudo gedit /etc/bumblebee/bumblebee.conf

Change these in the file and save:

Driver="empty or whatever" to  Driver=nvidia
kernelDriver=nvidia-current to KernelDriver=nvidia

sudo update-initramfs -u

Booted up might be kind of buggy had to Ctrl+Alt+F6 and then Ctrl+Alt+F8 to get out of black screen of panic for Mint 13.

Ubuntu uses different keys Ctrl+Alt+F1 and then Ctrl+Alt+F7.

sudo reboot

Then run your update manager. My bumblebee did not work until OS go the new stuff.

Try optirun glxgears in a terminal.

These are the sites that help me a lot for my Samsung:

http://forums.linuxmint.com/viewtopic.php?f=59&t=106262 and http://openideals.org/2012/04/15/tuning-ubuntu-on-samsung-series-7-laptop/

I have run:

optirun firefox    and played www.quakelive.com 
optirun glxgears, and optirun glxspheres.

pluma is an text editor on mint 13 mate maya.

Here is what this file look like:

sudo pluma /etc/modprobe.d/blacklist.conf

# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.

blacklist amd76x_edac
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv









 Here is what this file look like,
sudo pluma /etc/bumblebee/bumblebee.conf

# Configuration file for Bumblebee. Values should **not** be put between quotes
## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia

## Client options. Will take effect on the next optirun executed.
[optirun]
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false
# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
Module=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia
## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau
share|improve this answer

You have accepted an answer to your question, but did you ever resolve this problem? In case you haven't, and for other people looking for step-by-step instructions on getting the Optimus GT650M working with bumblebee and the NVidia proprietary driver, you should check out a recipe I wrote here: http://eternalvoid.net/tutorials/linux-optimus-gt650m/

Basically, until bumblebee 3.0.1 and nvidia-current 304.22b are in an Ubuntu repository, you will probably have to follow a method similar to my recipe to be able to use your NVidia card.

In short, this involves installing a new beta version of the NVidia driver (the official version), but you have to use many command-line switches when installing it, so that you get it in a non-standard location, and so it doesn't remove all your existing OpenGL stuff.

Then you have to install bumblebee 3.0.1 from their git repository, and configure it to be able to find all the NVidia libraries, but also to use an Intel driver when accessing the framebuffer.

Full instructions are at the link I provided, but please only follow them on a fresh install of Ubuntu, with everything backed up somewhere else.

share|improve this answer

You want to use the Bumblebee packaged drivers for your system. You should be able to solve your problem by following the same procedure as here: Switchable laptop graphics issues on Ubuntu 12.04?

PS. Don't use ironhide or x-swat for an Optimus graphics card. People are spreading outdated information.

share|improve this answer
    
I did what they said in the procedure, however when i ran optirun glxspheres I get this output [ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ERROR]Aborting because fallback start is disabled. Looking at the sudo apt-get update output i see this (3 of them Sources, amd64, and i386) W: Failed to fetch http://ppa.launchpad.net/mj-casalogic/bumblebee/ubuntu/dists/precise/main/binary‌​-i386/Packages 404 Not Found –  twf0001 Jul 12 '12 at 15:07
    
Also the original problem of not recognizing the GPU model has not been resolved –  twf0001 Jul 12 '12 at 15:14
    
What do you mean by "recognizing the GPU model", I thought you said you had 650M? You seem to be suffering from the same bug as this person: the Nvidia Geforce GT 650M bug –  Sepero Jul 13 '12 at 7:08
    
I know it is the 650M, but the computer doesn't display this –  twf0001 Jul 15 '12 at 3:25
    
It doesn't display it on my system either. I have a GT 630M –  Sepero Jul 15 '12 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.