Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased a new HP Pavilion HPE desktop running Windows 7. I am trying to install a dual-boot system with 12.04. However, when I run the LiveCD I only get as far as the "Install" window where you can select the partitions for your drives. On the bottom where it says "device for boot loader installation" I have "/dev/sda" and cannot select any other devices.

All the options to change the drives are greyed out, most likely because there are no drives in the window. I partitioned my largest drive using the tools within Windows, then booted into the CD, but nothing shows up. I then used Gparted to change the new space from unallocated to an /ext2, and still nothing shows up.

The installer does not recognize anything, but when I go into an Ubuntu session and use the disk utility manager I can see the partitions I made. Anything I do has to be done outside of the installer.

I have no files on this new computer, so this is the perfect time to install a parallel OS. I would like avoid completely reinstalling Windows, however. I've been over the forums many times, but all the answers I've found have not worked for me. I also tried flagging the new, empty partition as boot, but that screwed Windows up.

Also, the WUBI installer hits the same point and quits. I know that the disk itself is fine because I just made another dual boot system on a Gateway PC. This makes me think something within this computer is preventing the installer from "seeing" the drives. Any help would be much appreciated!

Edit in response: The main part of the partitioning window shows no partitions, everything is blank. There is no way to add partitions, and all the buttons are useless. I've tried defragging my drive multiple times, and I also used the same disk to dual-boot another PC with no problems, so it's not the disk, it's definitely the computer.

share|improve this question
The boot loader needs to be installed to /dev/sda, so that is normal. Does the main part of the partitioning window see the partitions? – psusi Jul 12 '12 at 2:05

When the installer gives you the selection to install grub to /dev/sda only, that's normal. You see, in Linux, partitions and disks are represented this way:

  • Disks are represented as an entry in /dev with no number at the end. sdas are SATA disks, hdas are PATA disks (CD drives are usually cdrom, cd, cdrw. Same for DVDs).
  • Partitions, however, are represented as the device they are on (the above point) followed by a number. So, while /dev/sda is your disk, /dev/sda1 is a partition on that disk.

The boot loader doesn't install to a partition -- it installs to a disk. That's why the install is asking whether you want to install on /dev/sda, which is a disk.

share|improve this answer

I was having an identical problem also on an HP Pavilion machine. I booted Ubuntu from CD and wanted to move to a permanent installation (not trying to create a dual boot machine, actually, a pure Linux box). I created all of the partitions with GParted but the installation tool didn't see them. Interesting bit is that fdisk -l did not see the partitions either.

The fix was to run sudo dmraid -rE . Once that was done, the installation tool saw the hard disk.

In my case (Arthur Borsboom) this fix removes something related to Nvidia RAID (nvraid), which I have been using in the past for Windows.

share|improve this answer
Thanks, this worked for my old Dell that has fakeraid, after I swapped out a dead hard drive. – cha Oct 5 '12 at 16:48

Go through this link Ubuntu 12.10 installer does not detect drive partitions

Hope it may help...

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Peachy Nov 9 '12 at 4:51

I went into Rescue mode and dropped to a shell inside the installer.
Then ran the sudo dmraid -rE command as mentioned above because the system I'm using also has the nVidia Raid card.
Once that was done, the installer saw the drive just fine.


share|improve this answer
Your answer would be more helpful, if you can, briefly, explain how to get into rescue mode. – Kevin Bowen Feb 19 '13 at 5:27
will the usage of this command jeopardize the functioning of the nvidia card on the windows partition? – Mutewinter Oct 25 '13 at 21:31

protected by Community Nov 8 '13 at 17:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.