Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Komodo Edit from a download (wasn't available in Software Center.) I want to be able to open .php files in Komodo, but when I right-click and choose Open With Other Application, Komodo doesn't display anywhere in the list. How can I add it to the list?

enter image description here

share|improve this question
    
Great question, great answer... but what is with the problem! This issue didn't exist in earlier versions I remember being able to previously browse for another application, and now that feature is gone. This is stupid. I can understand that not all programs can open a target in the same way, but WHEN that happens manual configuration as follows is in order but the default should be to call the application and see if it can take the target as a parameter! –  Quaternion Mar 25 at 17:52

5 Answers 5

Only applications available in the Launcher/Dash show in the Other Applications list.

Komodo Edit 7 creates an icon on your desktop by default:

enter image description here

To put Komodo Edit in the Launcher list and thus make it available in Other Applications, you must do the following:

  1. Open the terminal with Ctrl-Alt-T
  2. Type or paste:

    sudo cp ~/Desktop/komodo-edit-7.desktop /usr/share/applications/
    

    or for the newer version (Komodo Edit 8):

    sudo cp ~/Desktop/komodo-edit-8.desktop /usr/share/applications/
    

    Note that before this step, in order to run Komodo Edit 8 (whose file was named komodo-edit-8.desktop) by simply clicking on the Desktop icon, I was getting an "Untrusted Application Launcher." I fixed this by making it executable by doing

    chmod +x ~/Desktop/komodo-edit-8.desktop
    
  3. Exit the terminal.

  4. Check that Komodo Edit shows up in the Dash (it may take a few moments):

    enter image description here

  5. Now, it should also show in the Other Applications list for php (and other) files:

    enter image description here

share|improve this answer
    
This is an older version of Komodo - it was installed about a year ago, and definitely did not create an icon on the desktop. But it IS already available in the dash, so I don't get why it's not in the applications list. –  EmmyS Jul 12 '12 at 15:05
    
@EmmyS, please find the Komodo Edit desktop file in /usr/share/Applications and share its content to better help us troubleshoot your problem (instructions in this answer) –  izx Jul 13 '12 at 22:19
1  
I rather put it in my home directory's share/applications folder as Komodo by default installs itself to my home directory so it's not available for other users. So the command modifies to cp ~/Desktop/komodo-ide-8.desktop ~/.local/share/applications/ –  Attila Fulop Oct 9 '13 at 8:55

You could simply append a blank space and %F to the Exec parameter in the application.desktop file of your installed application.

You mentioned you didn't install from the software center so add a "komodo.desktop" file in /usr/share/applications/1 or ~/.local/share/applications/2, which would be very similar to the one I'm showing, just change the Name, Exec, Icon (etc) values to reflect your custom installation of komodo on your PC

Like so:
(using sublime as example because I don't use komodo)

an image of gedit using monokai color theme and showing the Exec line and the &F parameter highlighted

Explanation: the %F option activates the ability of passing arguments to your application, so if ubuntu can pass an argument it will activate the "opening file with" option on the context menus, and will pass the file as an argument3. Boom, that's all there is too it, not complicated at all.


Notes:
1: You will need root privileges to modify anything on this directory. (you could use sudo nano app.desktop from the "terminal" or open gedit with root privileges entering gksu gedit & , it will ask for your password of course)
2: ~ stands for your user home directory (which really resides in /home/username/blabla...), and that the /.local/ directory is usually hidden, if you are using nautilus to "explore" your file system you can hit ctrl+h to show hidden files.
3: If your application doesn't support passing arguments it wont work.

share|improve this answer

Open Nautilus by the terminal with

sudo nautilus

then, using Nautilus go to /usr/share/applications/ and look for the application you want to add to the "Open With" list. Copy the link on the desktop by copy-paste. Launch a text editor like Gedit ant drag the file you copied on the desktop in the text editor. One of the last lines should be

NoDisplay=false

So just replace "false" with "true" and save the file. Then drag the file you modified in /usr/share/applications/ and overwrite the old one.

Then open again the "Open with" menu and you will see that application.

share|improve this answer

Based on vine_user's method, but with a different approach.

I normally download Blender from the official website, then use Alcarte / Main Menu software to create the menu link. After that, you will find the menu at "/.local/share/applications".

Now, see which one of the .desktop files is yours (and make sure it's executable). Right Click on it, hit Properties. Then, in the Command field, right after the command stated there, add %U.

That's it! It should now show in your menu.

share|improve this answer

If you have /usr/share/applications/application.desktop, change Exec=command to Exec=command %F in the file.

application: the name of application.

command: the name of application command.

like this:

sudo sed -i 's/Exec=command/Exec=command %F/' application.desktop

Then, you will be able to add the application to the list.

Please arrange the portion of Exec=command according to your application.desktop file.

It may be necessary to change MimeType=applications/php etc., if it is not still displayed.

Although it may be needlessness in this question, I consider that it may be effective in other applications.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.