Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run 12.04 with gnome-classic. I wanted to get autologin since I am the only user. I unlocked the user account GUI under settings, switched the slider to ON, then locked the GIU. Since then a reboot stops at stopping system V runlevel compatibility.

Pressing Ctrl+Alt+F1 then gives me a command-line login. Typing startx starts Unity instead of Gnome. In that, I cannot unlock the User Accounts GUI under settings to set the autologin slider back to OFF.

share|improve this question
@Eliah Kagan: Many thanks. I have unset the root password with your command. I am not sure but in all my mucking around before I might also have unlocked it. The rootsudo link is very informative. I wasn't aware of graphical sudo usage. I do understand the Ubuntu sudo philosophy (my earlier Mac did the same). I still wonder what I did wrong in the first place. Shifting the Automatic login slider to ON in the User Accounts GUI seems to – user76575 Jul 12 '12 at 13:23
I'm glad it's working now, and I don't blame you at all for not wanting to continue messing around with a production machine that you now have working properly. – Eliah Kagan Jul 12 '12 at 14:17

You can log in on a virtual console (you must be doing that after pressing Ctrl+Alt+F1 but before running startx). So if the problem really is that you set a blank password for yourself (as MeM suggested), you can fix that easily by running:


Then change it to something that's not blank. You'll know it was changed successfully because the new password will work to log on at a virtual console. (You can type exit or logout to log off, then try logging back on.)

If that doesn't fix the problem, try disabling automatic login by editing /etc/lightdm/lightdm.conf with:

sudo nano -w /etc/lightdm/lightdm.conf

Remove the text that makes automatic login happen. That text looks like:

autologin-user=<YOUR USER>

Source: htorque's answer to How do I enable auto-login in LightDM?

share|improve this answer
Thank you. I now found the way to unlock the User Accounts GUI in the All Settings GUI. Earlier, I had indeed tried editing /etc/lightdm/lightdm.conf and I had also changed my own user admin account password and added a root account password following the excellent – Rob Jul 12 '12 at 8:21 Sorry, am new to this forum and keep hitting return which upsets commenting and 5 min isnt enough. I then used CNTRL+ALT+F1 to login as root, typed startx, get a fresh Unity screen, opened the All settings / Uer accountsGUI, clikced my own account open, slid the autologin slider to off, rebooted. OK. Maybe the bug was trying to set the autologin sider to ON in Gnome-classic? Should I know remove the root password again? How? – Rob Jul 12 '12 at 8:45
@Rob If you really did set a password for the root account, you can re-disable it with sudo passwd -dl root. But you didn't have to do that; if you wanted to run X11 is root (generally not recommended), you could have used sudo startx. Once you have a GUI, you can run graphical programs in it with gksu/gksudo. Here are the details.. BTW your link has broken images--this is the correct link. – Eliah Kagan Jul 12 '12 at 11:38

If it happened because you didn't specify a password for the adm account or set it to not asking for a password on log in, I recomend resetting the password, here is how to do it (either one):

Then it should work. (Yes this is a lousy bug on Ubuntu, hope they fix it.) If that is not the case, then I don't have a clue either!

share|improve this answer
Do you know if this bug has been reported? If so, can you edit your answer to include a link to the bug report? If not, it should be. – Eliah Kagan Jul 12 '12 at 2:10
Thank you. I now found the solution. Earlier, I had indeed tried editing /etc/lightdm/lightdm.conf and I had also changed my own user admin account password and added a root account password following this excellent recipe. To no avail. I now logged in with CNTRL+ALT+F1 as root with this root passwd, typed startx, got a fresh Unity startup screen, went into the All Settings/User Accounts GUI, clicked my user account open under Other Accounts. No lock/unlock clicker now. Shifting autologin to off did the trick. Maybe bug in Gnome-classic? – Rob Jul 12 '12 at 8:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.