Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to run glxgears or ssh to a machine and use OpenGL with the -X flag, I get this error message:

Xlib:  extension "GLX" missing on display ":0".
Error: couldn't get an RGB, Double-buffered visual

The output of lspci is:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520M] (rev a1)
07:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)
08:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
09:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
0f:00.0 USB controller: Texas Instruments Device 8241 (rev 02)

This is a fresh install of ubuntu, and strangely the proprietary NVIDIA driver is not listed under Additional Drivers. The NVIDIA X Server Settings tells me

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

If I do this, I am greeted with a 640x480 screen in addition to the above problems (I fixed this particular problem with mv /etc/X11/xorg.config.backup /etc/X11/xorg.config)

The output of ldd $(which glxgears) is

linux-vdso.so.1 =>  (0x00007fffc0bff000)
libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1 (0x00007f6e0f10d000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f6e0ee13000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f6e0eade000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6e0e721000)
libnvidia-tls.so.302.17 => /usr/lib/nvidia-current/tls/libnvidia-tls.so.302.17 (0x00007f6e0e51e000)
libnvidia-glcore.so.302.17 => /usr/lib/nvidia-current/libnvidia-glcore.so.302.17 (0x00007f6e0c16c000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f6e0bf5b000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f6e0bd57000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f6e0bb38000)
/lib64/ld-linux-x86-64.so.2 (0x00007f6e0f448000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f6e0b935000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f6e0b72f000)
share|improve this question
    
run ldd $(which glxgears) and check if glxgears is properly linked and what OpenGL library is using. You can also run sudo apt-get update --fix-missing && sudo apt-get upgrade -y && sudo apt-get install -f to check for possible problems with your local apt manager. –  user827992 Jul 13 '12 at 22:03
    
I've added the output of ldd $(which glxgears) There doesn't seem to be any problems with apt-get... –  da code monkey Jul 15 '12 at 2:58
    
ok, so the executable seems to be properly linked, let's go with the drivers. bugs.launchpad.net/ubuntu/+source/nvidia-settings/+bug/523108/… follow those steps. –  user827992 Jul 15 '12 at 10:09
    
Ok, on step 3 I get an error update-alternatives: error: no alternatives for gl_conf. –  da code monkey Jul 15 '12 at 13:16
    
askubuntu.com/a/17068/72589 try the section about "switching to Nvidia" –  user827992 Jul 15 '12 at 13:24

1 Answer 1

up vote 1 down vote accepted
+50

You have a hybrid Intel/Nvidia graphics system. I believe that this should work to get your Intel graphics running.

sudo apt-get install mesa-utils

To get your Nvidia graphics working, see this link: Switchable laptop graphics issues on Ubuntu 12.04?

share|improve this answer
    
thanks, that fixed it –  da code monkey Jul 15 '12 at 22:01
    
No problem man. I had this same issue myself and it sucked. lol –  Sepero Jul 18 '12 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.