Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have bought a Lenovo Ideapad u410 last week. Normally I only use Ubuntu, so I tried to install it. After a few (or a few more ;) ) hours I got it working. I used both systems, Ubuntu and Windows, without problems. Now my Windows system dosen't boot anymore, but that is another story...

Today I noticed that the battery life is only about 3 hours (the u410 should have a battery life of about 9 hours!). Also the ultrabook gets very, very hot.

Does anyone know how I can increase the battery life and handle this "gets too hot" thing? I'm really concerned about my new baby =)

share|improve this question
    
Try referring this. –  atenz Jul 11 '12 at 18:39
2  
Take a look at this for battery optimization: askubuntu.com/questions/147094/… –  Mitch Jul 11 '12 at 18:40
add comment

3 Answers 3

sudo apt-get install powertop
sudo powertop 

Other people report it too, not much help in certain faq-like forums. http://communities.intel.com/thread/30526

I'd check first of all if it's related to the power regression issue 3.4-3.5, it seems to affect other Lenovos too (related to some very old chips in those new systems). Try running powertop after killing X to see if it is graphics related. It could also be connected to RC6-states not being activated like they should. http://www.phoronix.com/scan.php?page=news_item&px=MTE1MTI

Don't use conservative CPU scheduler, on-demand is recommended as the appropriate by Intel and all other authoritative sources. The names are a bit misleading, just run on-demand on such a laptop.

This laptop has both the discrete Intel GPU and an Nvidia GPU, try deactivating one of them and check for power consumption.

I advise you to create a proper bug report for this issue instead of using askubuntu.com - most advice in here is not so qualified. Such a large power consumption as in the U410 on Ubuntu current is not an issue of tweaking power settings - it signifies some actual defect somewhere. Relatedly, do you also experience issues with the built-in microphone?

Good luck!

share|improve this answer
add comment
sudo add-apt-repository ppa:artfwo/ppa
sudo apt-get update
sudo apt-get install indicator-cpufreq

When you reboot your system there will be an icon on the tray. Select the conservative plan for your cpu.

share|improve this answer
add comment

protected by Community Sep 8 '12 at 8:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.