Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I boot, it goes straight into tty1. I have tried everything I could find online to solve this problem. I believe it has something to do with the Nvidia drivers. But reinstalling them in every possible way makes no difference. I am at a complete loss. My question is very similar to this question which never got answered: mountall: Disconnected from Plymouth

the boot ends with this:

mountall: Plymouth command failed
mountall: Disconnected from Plymouth

in syslog:

NVRM: Your system is not currently configured to drive a VGA console
NVRM: on the primary VGA device. The NVIDIA Linux grphics driver
NVRM: requires the use of a text-mode VGA console. Use of other console
NVRM: drivers including, but not limited to, vesafb, may result in
NVRM: corruption and stability problems, and is not supported.

in Xorg.0.log:

(EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
(EE) NVIDIA(0): Failing initialization of X screen 0
(EE) NVIDIA(0): Screen(s) found, but none have a usable configuration.
Fatal server error: no screens found
Server terminated with error (1). Closing log file.

I'm running 12.04 Precise on a 64-bit AMD. I have an Nvidia GT 630 video card.

share|improve this question
    
Update: I bit the bullet and installed the the nouveau display drivers. This worked, but now I when I log in, I get kicked right back to the lightdm login screen. I believe this is because I ruined my swap file making it unmountable, after following the misguided advice of others who had similar problems. This then might be the (unfortunate) answer for people as stuck as me: sudo apt-get update sudo apt-get install xserver-xorg-video-nouveau –  Jason Hartley Jul 12 '12 at 17:44

1 Answer 1

Run:

jockey-text -cu 

Then:

jockey-text -l

If there is any disabled software there just enable it. For example:

jockey-text -e xorg:fglrx

That fixed this for me.

share|improve this answer
    
I'm half-tempted to install the Nvidia drivers again just to induce the inevitable failure so I can test this out. –  Jason Hartley Jul 27 '12 at 6:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.