Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I tried to boot Ubuntu with 9wm (which I had installed before), first modifying the GRUB boot from 'quiet splash' to 'text', after adding it to LightDM. As it doesn't worked, I've removed the LightDM entry and restored GRUB. But when I try to login with any window manager in LightDM, it just stops and opens LightDM again. If I try to run startx from a tty, it shows erros, saying all time that No protocol specified. What can I do?

UPDATE: It just happends with my user, logging with another one works.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Surprisingly, the workaround for this problem is very simple. Just remove all .Xauthority files in your home folder with this command:

rm ~/.Xauthority*
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.