Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried resetting the password of windows 7 Using chntpw command in Ubuntu . It showed success. But when I try to login from Windows it does not seem to be changed.

I first used live USB of Ubuntu 11.10 and did Try Ubuntu. Then I did:

sudo apt-get install chntpw

And then:

cd /media/Vista/Windows/System32/config
sudo chntpw -u username sam

I followed these instructions and got success like this:

Hives that have changed:
# Name
0 <sam>
Write hive files? (y/n) [n] : y
0 <sam> – OK .

But when I try to login to windows with blank password, I could not log in.

I also tried changing the password and showed success but I could not log in with that password.

share|improve this question
possible duplicate of Usage of chntpw – RobotHumans Jul 11 '12 at 7:19
Rather use Offline registry editor. – Misery Apr 9 '13 at 11:18
Reviewers: when this question was asked, 11.10 was on topic. – guntbert Jun 5 at 11:38

The 0.99.6 version of chntpw is totally disfunctional:

I struggled more than a hour to find this out.

Try to use 0.99.5 instead, it works for me:

share|improve this answer
1.00 seems dysfunctional as well. – palswim Dec 5 '14 at 21:42

To change Administrator password: sudo chntpw SAM. To change another users password: sudo chntpw -u <your-username> SAM Please note the Upper-case of the word SAM

share|improve this answer
When I tried using upper-case it showed some errors regarding the heive . So I used lowercase . I tried using both sudo chntpw sam and sudo chntpw -u username sam . It shows success also . But when I log in to windows it says incorrect password . Thank you . – Sandesh Yadav Jul 11 '12 at 7:53
How do you type your username if it contains accented letters? It's impossible. – Calmarius Oct 2 '13 at 20:38

The new version of chntpw doesn't work with windows 7. You have to go back a version.

share|improve this answer
Can you specify the versions you are talking about? – belacqua Jun 15 '13 at 0:40
1.00 was failing, but 0.99.6 worked. – palswim Dec 5 '14 at 21:42

I had the same problem. What worked for me was using chntpw to unlock the administrator account, which was the only function of chntpw that worked. Then I booted windows, logged in as Administrator, and cleared the users' password with the users app in control panel.

share|improve this answer

I am using Ubuntu 12 and chntpw 0.99.5. I have successfully reset my forgotten password by following this guide. If there are multiply Windows systems installed on your hard drive, make sure you choose the desired SAM database.

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – David Edwards Apr 9 '14 at 15:41
There is no problem with the steps that Sandesh did. Only the version of chntpw will make difference. chntpw 0.99.5 works from my side. – user267077 Apr 10 '14 at 6:22
Then it sounds like your answer is a duplicate of the top-voted answer already here. – David Edwards Apr 10 '14 at 10:45

protected by Community Jun 29 at 8:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.