Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an AMD Athlon X2 260 processor (dual core @ 3.2 Ghz - No over clocking, default BIOS values) running on an ASUS motherboard. It is a brand new motherboard and has 4 GB RAM. I have installed 12.04 -64 bit on it. All updates installed

Firstly, it takes about 13 secs to log in and see the desktop wallpaper after entering the password. Beyond that, it takes 3 seconds more to see the Unity Bar and the icons.

Whenever I am opening any application for the first time, it takes anywhere between 10 to 30 seconds. For e.g. Firefox browser (25 secs) , Gwibber (15 secs), Empathy (12 secs), Evolution (27 secs), Home folder (7 secs), Writer (17 secs), Calc (12 secs), Impress (14 secs), Jokosher & Audicity (22 secs), Ubuntu Software Center (26 secs), Filezilla (10 secs), Cheese (11 secs)

It is extremely annoying to wait for the application to open for the first time. Once the application is opened, then probably it remains in the cache and hence, if I close the app and open it again, it opens faster than the blink of an eye.

I have enabled desktop screenlets to check the processor & RAM utilization. The values are quite normal. RAM fluctuates between 15% to 30% depending on how many apps I have opened. (After the PC boots, memory utilization is 386 MB out of 4 GB with no utilization of SWAP space) and processor utilization fluctuates between 2% to 20% with sporadic peaks reaching 65% to 75%.

As and when I start opening apps, memory utilization goes up and if I open all of the above apps, it reaches to about 1.4 GB.

Following is the hardware configuration

AMD Athlon X2 260

ASUS motherboard M2xxxx-LE

4 GB 1333 Mhz RAM

80 GB Seagate SATA HDD for the OS

1TB Seagate x 2 for data storage

Standard USB Keyboard Mouse

Logitech C11 USB Camera

GEForce 7800 PCI Express Display Card - 512 MB Ram

Dell 22" LED and Samsung 20" LED monitors

Ubuntu 12.04 LTS 64 bit

I have a partition where I have Ubuntu 11.10 - 64 bit running. Surprisingly, that installation is working very nicely. Quite decent speed. Everything under 2/3 seconds

Any help to resolve the issue is welcome

Best Regards

share|improve this question
    
What model is the 80GB seagate? –  Mitch Jul 11 '12 at 5:58
    
Seagate Barracuda 7200.10 ST380815AS 80GB 7200 RPM 8MB Cache –  Ubuntu Ingrained Jul 11 '12 at 8:39
    
Have you tried updating the BIOS? –  Mitch Jul 11 '12 at 9:12
    
Hey tried doing that as well...does not seem to be helping me on that. I think, there is a problem with the display card drivers. After I removed the display card and use the on-board display card, speed seems to have increased by 50%. The same display card seems to be working gr8 on a Linux Mint and Windows 8 operating System...quite weird.... –  Ubuntu Ingrained Oct 27 '12 at 15:51
    
Is the partition for Ubuntu 11.10 on the 80 GB or 1 TB HDD? I would suspect performance problems on the 80 GB HDD, could you confirm that by doing some HDD benchmarking (e.g. try iozone)? –  Huygens Mar 15 '13 at 10:09
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.