Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running 10.04 and 10.10 (maybe before these) I've noticed that for some dialogs to accept input the mouse cursor must be in the parent window. This is the case even though from the window highlighting the dialog box is in focus.

Is there exposed configuration control for this behavior? I'm particularly interested in GUI controls. I've looked at mouse and window preferences - no joy.

share|improve this question
    
are you running compiz? –  RolandiXor Dec 5 '10 at 1:28
    
Please append the necessary steps to replicate the problem to your question. That'd be tremendously helpful! –  Stefano Palazzo Dec 5 '10 at 9:43
add comment

1 Answer

Have you enabled a feature called "focus follows mouse" at some point? The behavior you describe sounds like this option is turned on on your system. Check the window preferences, or else gconf (using gconf-editor) for a setting to that effect. Otherwise perhaps googling the term will help you.

share|improve this answer
    
No, I've used that mode on Solaris. After Stefano's comment I tried some of the common apps and couldn't find a replication sequence that I could present. –  marawuti Dec 7 '10 at 5:00
    
How does one retract a question? –  marawuti Dec 7 '10 at 5:01
    
There's a "delete" link just under your question. Should be next to "close" and "edit" –  Jeremy Dec 7 '10 at 5:53
    
But you could leave the question here, because it's a good question and has a correct answer. it might help others. –  Torben Gundtofte-Bruun Jan 5 '11 at 16:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.