Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is happening on Ubuntu Release 12.04 (precise) 64-bit Kernel Linux 3.2.0-25-virtual

I'm trying to increase the number of open files allowed for a user. This is for an my ecplise java application where the current limit of 1024 is not enough.

According to the posts I've found so far, I should be able to put lines into

/etc/security/limits.conf like this;

soft nofile 4096
hard nofile 4096

to increase the number of open files allowed for all users.

But, that's not working for me, and I think the problem is not related to that file.

For all users, the default limit is 1024, regardless of what is in /etc/security/limits.conf (I have been rebooting after changing that file)

$ ulimit -n
1024

Now, despite the entries in /etc/security/limits.conf I can't increase that;

$ ulimit -n 2048

-bash: ulimit: open files: cannot modify limit: Operation not permitted The weird part is that I can change the limit downwards, but can't change it upwards - even to go back to a number which is below the original limit;

$ ulimit -n 800
$ ulimit -n
800

$ ulimit -n 900

-bash: ulimit: open files: cannot modify limit: Operation not permitted

As root, I can change that limit to whatever I want, up or down. It doesn't even seem to care about the supposedly system-wide limit in /proc/sys/fs/file-max

# cat /proc/sys/fs/file-max
188897

# ulimit -n 188898
# ulimit -n 
188898

But even I get eclipse to run as root, my application stills crash becuase of "Too Many Open File" exception!

So far, I haven't found any way to increase the open files limit for a non-root user.

How should I properly do this? I have looked at all the posted and tried the given options but no luck!

share|improve this question
    
Also, note that after you edit /etc/security/limits.conf, you may have to logout and then back in before you can use the new max limit. I did this, and was baffled by ulimit -Hs still showing 1000 when I had just raised it to 1000000! Then I logged out and back in, and ulimit showed the new amount. –  Cerin Mar 15 at 21:28
add comment

migrated from stackoverflow.com Jul 11 '12 at 2:29

This question came from our site for professional and enthusiast programmers.

2 Answers

the ulimit command by default changes the HARD limits, which you (a user) can lower, but cannot raise.

Use the -S option to change the SOFT limit, which can range from 0-{HARD}.

I have actually aliased 'ulimit' to 'ulimit -S', so it defaults to the soft limits all the time.

alias ulimit='ulimit -S'

As for your issue, you're missing a column in your entries in limits.conf

There should be FOUR colums, the first is missing in your example.

* soft nofile 4096
* hard nofile 4096

The first column describes WHO the limit is to apply for. '*' is a wildcard, meaning all users. To raise the limits for root, you have to explicitly enter 'root' instead of '*'.

You also need to edit /etc/pam.d/common-session* and add the following line to the end:

session required pam_limits.so

share|improve this answer
    
How do I change the Hard limit for the maximum number of open file descriptors? My problem is that I need to allow my Eclipse application to have as many as open file as it wants but the limit of 4096 is not enough and I want to set it to as high as possible maybe 500000. My setting in the limits.conf is as you mentioned with the star and still the Hard limit is not moving. –  iCode Jul 11 '12 at 4:13
    
did you logout/reboot this time? ulimit -a will show you all the limits, so you can compare to see if they've changed. –  lornix Jul 11 '12 at 4:20
    
yes, I modified the /etc/security/limits.conf file only and reboot. after reboot, the ulimit -Hn500000 command still throws bash: ulimit: open files: cannot modify limit: Operation not permitted error. –  iCode Jul 11 '12 at 4:53
    
Well, 500,000 IS a bit large. I doubt you've got enough RAM to contain all the file descriptors for that many open files. Try something a bit smaller, say 65,000 or less. Although the docs say it should accept unlimited as a value too, also infinity, both should remove restrictions. –  lornix Jul 11 '12 at 7:51
1  
Well, you discovered the value of /proc/sys/fs/file-max was 188,897... So I'd say your upper limit is between 188,000 (allowed) and 500,000 (not allowed). Boggles the mind that you've got something that requires over 65000 open files simultaneously. Wow. Usually that's handled on big-iron. I'd be suspicious of a programming, uh, misconception. (With all due respect, please) –  lornix Jul 11 '12 at 21:13
show 4 more comments

If you use soft and hard limits on a per user basis you can use something like:

su USER --shell /bin/bash --command "ulimit -n"

to check wether your settings are working for that specific user or not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.