Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have created a Network Bridge in Ubuntu 11.10 and have a second computer accessing the network and internet through the bridge. The bridge comes up and is active before the log on screen but after about 30 mins of idle time for the Ubuntu computer the bridge becomes disabled. I can no longer ping the bridge from the second computer. I can type "sudo /etc/init.d/networking restart" and I can start using the internet through the bridge again.

I have tried modifying my power settings, telling the computer to never to go sleep or hibernate.

I think there is something simple that I am missing but my adapters config file consists of:

auto lo eth0 eth1 bridge0

iface lo inet loopback

iface eth0 inet manual

iface eth1 inet manual

iface bridge0 inet static
address x.x.x.x
netmask x.x.x.x
network x.x.x.x
broadcast x.x.x.x
gateway x.x.x.x
nameservers x.x.x.x
bridge_ports eth0 eth1
pre-up ip link set eth0 promisc on
pre-up ip link set eth1 promisc on
bridge_fd 0
bridge_hello 2
bridge_maxage 12
bridge_stp off
ip link set bridge0 promisc on

Not sure if I set something I should not of or if there is a setting that I am missing to prevent this. I want this connection to be running when the computer boots without a user being logged in, which is currently how it is working.

share|improve this question

1 Answer 1

You could try the following settings:

auto lo 

auto eth0 

iface eth0 inet static

auto eth1 

iface eth0 inet static

auto bridge0

iface bridge0 inet static
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.