Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed steam and downloaded dawn of war, winters assault and dark crusade they installed no problem and the opening cut scenes play ok but when I get the first load screen the graphics go funny the bottom half goes a multitude of pixelated colours and the top half does nothing.

Main Menu

when the main menu appears here is a green wire frame like outline of the background of the right hand side panel and if I go to the options screen there is no background and I can see the main menu screen directly behind it after adjusting the graphics settings the areas affected are smaller but still noticeable

Race select

once I click the Campaign the loading screen is a multitude of pixelated colours like the first one and has the top half missing and when I try to choose a race the models look like there still in the early stages of 3d modelling with a green wire frame or parts just aren’t there for instance the buttons on this screen are totally invisible until you hover over them and the background just isn’t there

The campaign

the main campaign has massive sections of the map missing or looks like its just been wire framed the mini map is half missing to this happens on all three games.

Does anyone know what’s causing this issue I think it's the graphics card in the laptop. I really want to know if its fixable and I can’t just play this game on my windows laptop because I keep getting access violation errors. The version of linux I’m using is Ubuntu 12.04 and I have the latest version of wine and as of this post have all available updates.

share|improve this question

closed as off topic by mikewhatever, izx, jokerdino, jrg Jul 12 '12 at 14:15

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Software is not perfect, that's life. Anyway, this is probably way off topic. –  mikewhatever Jul 10 '12 at 23:58
    
I know its not perfect but it works on othere linux based mechines i need a way to fix it or at least a defanitve answer to what the problem is –  wheels Jul 11 '12 at 0:15
    
^^^ You should take this up and file bugs with Steam/Valve/the developers. –  izx Jul 11 '12 at 0:41
    
If possible, please edit your question to include screenshots of the glitches. These may be easier for someone who has also seen such problems to identify and suggest a possible workaround. –  izx Jul 11 '12 at 0:49

Browse other questions tagged or ask your own question.