Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I send a mail, it takes several minutes (~20) to finish this task. I can see a status bar item, percents increasing. I wouldn't mind much; the problem is that until it's done, I can't see the mail in the Sent folder and can't work with it.

This behavior started without any reconfiguration. Other users of the same mail server do not experience this trouble.

How can I fix this?

Versions: Ubuntu 11.04 Evolution 2.32.2

Update: I found out that the messages are actually staying in Outbox and not outgoing at all if one particular SMTP server is used. When I tried to "Flush" the Outbox, it shown "Sending...", but nothing changed nor was sent. When I try to "expunge" outbox, Evolution says:

MBOX file corrupted, expected From: but didn't find.

and later

Summary and folder mismatch, even after a sync

Any idea how to fix this? Preferably without need to drop & set up everything anew.

And where does Evolution store it's .mbox files? ~/.evolution does not exist. ~/.gconf/apps/evolution/ only contains configuration.

share|improve this question
1  
Is it at least closing the message editor window for you -- or does that stay open until the mail was sent completely? If it got closed, you should be able to see the mail in the outgoing folder while it is still being transmitted. For me the most annoying part is it keeps the editor window open all the time (did not do this in previous versions -- and I don't know how to change that). –  Izzy Jul 11 '12 at 8:52
    
Indeed, it's in Outbox, I had the "local" tree collapsed all the time since I have all accounts as IMAP. Thanks. –  Ondra Žižka Jul 11 '12 at 15:24
    
My editor window closes right at clicking "send". Adding versions info to the question. –  Ondra Žižka Jul 11 '12 at 15:24
    
1) you're welcome -- glad I could help! 2) version makes the difference. I'm now on 12.04, and the editor window stays open all the time until the mail is successfully sent. THAT sucks! Don't want to think of my sanity if sending took as long as in your case... –  Izzy Jul 11 '12 at 15:52
    
PS: So was your question "how can I see the message while it is being sent" -- or was it "how can I find out (and fix) why it takes that long"? Maybe you edit your question to make this clear ;) –  Izzy Jul 11 '12 at 15:55
add comment

3 Answers 3

Answering the first part of the question (where can I see my message while it's being sent):

While being sent, the message can be found in the "Outbox", which is located in the "local tree" of the mail accounts. Only when sent successfully (i.e. delivered to the configured SMTP server -- which does not necessarily mean it already reached the recipient), it gets stored within the "Sent" folder.

share|improve this answer
add comment

Ondra, it would have been better you'd opened a new question instead of completely changing the topic :)

And where does Evolution store it's .mbox files?

Not sure about the .mbox files as I don't use local storage. But usually, all of Evolutions data files are located in ~/.local/share/evolution, while configuration stuff went to ~/.config/evolution. The third place involved you already discovered (~/.gconf/apps/evolution). Gone the days where things have been easy with everything located in ~/.evolution -- that folder is not used anymore at all with current versions.

How to fix this (trouble with certain SMTP server)?

Logs are helpful. Try contacting the servers admin, maybe it's not at all the fault of Evolution -- or the server's logs provide useful information to isolate the problem). Until solved, try using a different SMTP server: either the admin has a secondary you could use, or some other admin permits you to "relay" via his server.

share|improve this answer
    
I was considering asking another question but since it all evolved around a common problem, I wanted to keep it here. –  Ondra Žižka Jul 13 '12 at 16:00
1  
I see. So I take it the long delay was due to the broken mbox files, and then it fits ;) –  Izzy Jul 13 '12 at 17:07
add comment
up vote 0 down vote accepted

Ok so I have figured out few things.

1) The files are in MBOX format, but not named *.mbox.

2) They are stored in .local/share/evolution/mail/local, at least in my case.

3) Non-redundant data are stored in the files without suffix. The rest is generated and can be deleted manually and re-generated (.ibex, .index etc.)

4) Exporting backup and restoring from it did not help. Seems that evolution just gzips the files as is.

So what fixed it for me was:

  1. Close Evolution
  2. Delete /home/ondra/.local/share/evolution/mail/local/Outbox.* (NOT that without suffix)
  3. Launch Evolution

  4. Fix your SMTP if necessary to make all mails go.

  5. Flush Outbox to send pending messages and get them moved to IMAP server (deleted locally)
  6. Close Evolution
  7. Delete Oubox* - this time all Outbox files. All mails shown in Evolution at this time are probably broken and unrecoverable (easily). Outbox will be recreated.
  8. Delete folders.db - it will get recreated from the MBOX files
  9. Launch Evolution

Tadaa!

Sources:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.