Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my Ubuntu up to 12.04. Untill that, i can't use synaptic at all.

After trying to repair the issue through synaptics, it returns me:

    installArchives() failed: dpkg: dependency problems prevent configuration of wine1.4-i386:i386:
 wine1.4-i386:i386 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-i386:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4:
 wine1.4 depends on wine1.4-amd64 (= 1.4-0ubuntu4); however:
  Version of wine1.4-amd64 on system is 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 depends on wine1.4-i386 (= 1.4-0ubuntu4); however:No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already

  Package wine1.4-i386 is not installed.
  Version of wine1.4-i386:i386 on system is 1.4.1-0ubuntu1~precise1~ppa3.
dpkg: error processing wine1.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-common:
 wine1.4-common depends on wine1.4 (= 1.4-0ubuntu4); however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine1.4-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-amd64:
 wine1.4-amd64 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine:
 wine depends on wine1.4; however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine (--configure):
 dependency problems - leaving unconfigured
dpkg: depeNo apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
ndency problems prevent configuration of playonlinux:
 playonlinux depends on wine | wine-unstable; however:
  Package wine is not configured yet.
  Package wine1.4 which provides wine is not configured yet.
  Package wine-unstable is not installed.
dpkg: error processing playonlinux (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 wine1.4-i386:i386
 wine1.4
 wine1.4-common
 wine1.4-amd64
 wine
 playonlinux
Error in function: 
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: dependency problems prevent configuration of wine1.4:
 wine1.4 depends on wine1.4-amd64 (= 1.4-0ubuntu4); however:
  Version of wine1.4-amd64 on system is 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 depends on wine1.4-i386 (= 1.4-0ubuntu4); however:
  Package wine1.4-i386 is not installed.
  Version of wine1.4-i386:i386 on system is 1.4.1-0ubuntu1~precise1~ppa3.
dpkg: error processing wine1.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine:
 wine depends on wine1.4; however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-common:
 wine1.4-common depends on wine1.4 (= 1.4-0ubuntu4); however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine1.4-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-amd64:
 wine1.4-amd64 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-i386:i386:
 wine1.4-i386:i386 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-i386:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of playonlinux:
 playonlinux depends on wine | wine-unstable; however:
  Package wine is not configured yet.
  Package wine1.4 which provides wine is not configured yet.
  Package wine-unstable is not installed.
dpkg: error processing playonlinux (--configure):
 dependency problems - leaving unconfigured

I tried the following:

  • sudo apt-get clean
  • sudo apt-get autoclean
  • sudo apt-get install -f

And returnsme:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  wine1.4 wine1.4-common
Suggested packages:
  dosbox
The following packages will be upgraded:
  wine1.4 wine1.4-common
2 upgraded, 0 newly installed, 0 to remove and 110 not upgraded.
6 not fully installed or removed.
Need to get 0 B/1,126 kB of archives.
After this operation, 9,216 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of wine1.4-i386:i386:
 wine1.4-i386:i386 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-i386:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4:
 wine1.4 depends on wine1.4-amd64 (= 1.4-0ubuntu4); however:
  Version of wine1.4-amd64 on system is 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 depends on wine1.4-i386 (= 1.4-0ubuntu4); however:
  Package wine1.4-i386 is not installed.
  Version of wine1.4-i386:i386 on system is 1.4.1-0ubuntu1~precise1~ppa3.
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: error processing wine1.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-common:
 wine1.4-common depends on wine1.4 (= 1.4-0ubuntu4); however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine1.4-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine1.4-amd64:
 wine1.4-amd64 depends on wine1.4-common (= 1.4.1-0ubuntu1~precise1~ppa3); however:
  Version of wine1.4-common on system is 1.4-0ubuntu4.
dpkg: error processing wine1.4-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wine:
 wine depends on wine1.4; however:
  Package wine1.4 is not configured yet.
dpkg: error processing wine (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of playonlinux:
 playonlinux depends on wine | wine-unstable; however:
  PackagNo apport report written because the error message indicates its a followup error from a previous failure.
                                  No apport report written because the error message indicates its a followup error from a previous failure.
                                                            No apport report written because MaxReports is reached already
                                          No apport report written because MaxReports is reached already
                        e wine is not configured yet.
  Package wine1.4 which provides wine is not configured yet.
  Package wine-unstable is not installed.
dpkg: error processing playonlinux (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 wine1.4-i386:i386
 wine1.4
 wine1.4-common
 wine1.4-amd64
 wine
 playonlinux
E: Sub-process /usr/bin/dpkg returned an error code (1)

Cna anyone helpme? I've been searching for a sollution for days and still can't solve it.

Thanks! Pablo

share|improve this question

1 Answer 1

This problem is apparently caused by a mismatch between the version of wine1.4-i386 and wine1.4-amd64 (See comment 23 on this Launchpad page ). I was able to solve it by manually removing the PPA version of wine1.4-i386 (1.4.1-0ubuntu1~precise1~ppa3) and manually installing the 1.4-0ubuntu4.1 version (in your case, it looks like you would want 1.4-0ubuntu4), as follows:

  1. Disable the WINE PPA using Apper
  2. Download a .deb of the correct version of wine1.4-i386 from Launchpad (Again, you may want a slightly different version of the package)
  3. dpkg -r wine1.4-i386:i386
  4. dpkg -i < path of the .deb > (This should give you an error, but that's okay.)
  5. apt-get -f install (This should now work fine! Yay!)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.