Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had webmin installed on my 12.04 server and everything has been fine until recently. Now when I navigate to https:// myip:10000 I get a message saying the connection attempt is rejected. The last thing I did was set up a cron job to start utorrent webUI.

I tried reinstalling but no change. When I check with netstat I see a webmin entrance on port 10000. I've also reset the iptables and allowed everything. I'm at a loss as to what to do now.

share|improve this question

3 Answers 3

I've just experienced the same thing.

It looks like uTorrent was preventing webmin from starting up successfully. I tried various things to get uTorrent to start up on reboot alongside webmin but to no avail.

Eventually I got webmin working by removing the utorrent.conf file like so: sudo rm /etc/init/utorrent.conf and installed Transmission torrent client instead (which worked perfectly with no conflicts with webmin).

share|improve this answer

Although I don't use Ubuntu, the same thing appears to happen in other OS's like OpenSuse for example. I found that stopping the instance of utserver and then starting Webmin, then restarting utserver resolved my issue. Problem is that when you restart, you have the same issue again. It appears that utserver takes control of port 10000 for some reason. I guess another option would be to run webmin on a different port? I havent tried that yet....

share|improve this answer

Webmin uses port 10000 as we can see in netstat -nap, but if you are running utserver first of running webmin service it will also bind the port 10000 to it, because of a service of device pairing of utserver.

To avoid this bind another port in webmin at Webmin > Webmin Configuration > Ports and Addresses

Or in other hand you can disable the service of pairing in utserver Settings > Advanced > Search for net.discoverable and turn it to false > Save Settings > Restart utserver service (service utserver restart)

Check with netstat -nap if there is a bind of 127.0.0.1:10000 to utserver, doing that it will not be there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.