Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I boot the microphone is muted. I want it to be unmuted instead. Of course I can do it by 6 easy steps every time:

  1. press sound icon in the upper right of the screen.
  2. press "Sound settings..." item in the bottom.
  3. wait about 10 seconds until a window loads.
  4. switch to input tab.
  5. uncheck "Mute" checkbox near a microphone icon.
  6. close the window.

But I want it to be unmuted by default.

I guess that in linux world this should be changing 0 to 1 in some line in some configuration file, but I don't really know, where is this line located.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

From this previous answer:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

BTW, if you prefer to use the gnome editor rather than text editing in the terminal, you could also run gksudo gedit /etc/modprobe.d/alsa-base.conf. As far as I know, it is still better to run gksudo rather than sudo to start gnome/kde/unity applications with a GUI in super-user-mode.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.