Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently transferred a virtualbox machine from my laptop to my recently reinstalled desktop. The image works fine on my laptop, but when I try to boot it on my new machine, I get dumped to an "EFI Shell" where it asks me about my hard drives rather than booting the machine. I want it to boot to the actual machine image rather than this shell. How can I fix this?

share|improve this question

2 Answers 2

up vote 15 down vote accepted

It turns out that as I was messing around with getting the machine to load (due to Virtualization technologies being disabled), I clicked one too many items on the image settings page.

To fix this, go to the "Settings" page for the virtual machine, and click "System". Under the "motherboard" options, be sure that "Enable EFI (special OSes only)" is unchecked. Then click "OK", and try to boot the machine again. The option that was checked is basically how you get into the EFI Interface.

share|improve this answer
can you finnish your sentances? –  richard Jul 10 '12 at 20:54
Sorry, was looking for a good link what EFI is. Must have found it then forgot to actually link it in the post. –  Mark Hildreth Jul 10 '12 at 21:01
and the sentence in the question. –  richard Jul 10 '12 at 21:05
  1. in Efi shell: edit startup.nsh
  2. add line FS0:\EFI\Path\To\Desired.efi
  3. Save, reboot.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.