Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to boot Ubuntu on my computer. When I boot Ubuntu, it boots to a black screen. How can I fix this?

Table of Contents:

  1. If you are trying to install Ubuntu
  2. If you have a dual boot system
  3. If an update or something else caused your problem
share|improve this question
    
This happened to me on the weekend when I opened up my laptop to clean out the dust. I didn't even get to the grub screen - the only signs of life were the LEDs on my keyboard and the fans. After a short panic I opened it up again and realised I hadn't fully re-inserted one of the RAM cards. –  craq Aug 4 at 12:20

29 Answers 29

If you are trying to install Ubuntu

1. Ensuring your CD/DVD or USB flash drive burned/written correctly and not damaged:

2. Black/purple screen when you try to boot the LiveCD

The Ubuntu installer's startup portion is sometimes incompatible with certain graphics cards. Fixing it and getting to the Ubuntu Desktop to try or install it can often be surprisingly easy fix: the nomodeset parameter. To see if it works for you:

  • Boot from the Desktop Live CD and press the Down-Arrow when you see the below:

    enter image description here

  • Press Enter and select English:

    enter image description here

  • Press F6, use the arrow keys to go down to nomodeset, and press Enter. An x will appear to its left. Then press Esc, and press Enter to "Try Ubuntu without installing."

    enter image description here

You can also try acpi = off and nolapic if nomodset also shows up as a black screen.

3. Black screen

or

"you need to load kernel first" and "can not read file/cd0" errors

when installing to an UEFI capable machine:

Ubuntu's installer when attempting to run in UEFI mode will hang and stop due to different manufacturers implementing the UEFI specification in different ways will hang differently. To identify if your machine is booting installer UEFI mode you will see
enter image description here
REF: UEFI Community Ubuntu Documentation Section 2.4

If your machine is CSM capable (which is a full UEFI implementation with an emulated BIOS layer) after selecting any option from grub list system will hang at a black screen.

The picture above actually only confirms DVD/USB booted using UEFI and there will be some means in firmware settings to ensure drives are booted in order to make UEFI installer run - the solution to which may possibly be as simple as ensuring SATA set to AHCI - check your vendors manual to check this. Also check UEFI Community Documentation Section 2.3 for more details.

What you need to check is first disable SECURE BOOT in firmware settings. If that does not get Ubuntu installer running - Try disabling anything mentioning UEFI in firmware settings. Or
If you can not find UEFI settings then enable CSM - this will disable the UEFI booting of installer and then allow a legacy/bios install of Ubuntu.
Installing grub-efi afterwards will allow UEFI to be re-enabled. Again refer to UEFI Community Ubuntu Documentation this time at Section 4

Some machines use a full BIOS with an emulated UEFI layer which may throw errors as described ie "you need to load the kernel first" and "can not read file/cd0"

Not all of these machines implement Secure Boot. Simply selecting UEFI in BIOS settings will configure UEFI mode on hard drives. The information above may still be relative to your machine though regarding this. There is no solution for these errors and the workaround is to disable UEFI to enable Ubuntu installer to run in legacy mode. After which boot-repair can be used to install grub-efi which then allows/needs UEFI switched back on before Ubuntu will boot using UEFI. Once again referring to UEFI Community Ubuntu Documentation at Section 4


Black/purple screen after you boot Ubuntu for the first time

This usually happens because you have an Nvidia or AMD graphics card, or a laptop with Optimus or switchable graphics, and Ubuntu does not have the proprietary drivers installed to allow it to work with these.

The solution is to boot Ubuntu once in nomodeset mode (your screen may look weird) to bypass the black screen, download and install the drivers, and then reboot to fix it for ever.

  • Start your computer, and press the Right Shift when booting up, to get the Grub menu. Use the arrow keys to navigate/highlight the entry you want (usually the first one).

    enter image description here

  • Press e to edit that entry, which will show you the details:

    enter image description here

  • Find the linux entry as shown above, use the arrow keys to get to it, and then press the End key to get to that line's end (which may be on the next line!).

    enter image description here

    • Enter nomodeset as shown, and press Ctrl+X to boot to where you can successfully install your graphics drivers.

If you are running Ubuntu 12.04 or 12.10, and have a ATI/AMD graphics card, you have to follow the instructions here, otherwise you will run into this problem every time you restart your computer.

  1. Try the Alternate Installer - this is a text based installer that might work better than the liveCD depending on your hardware.
    If you do this, you may get a black screen before you even hit grub. A simple Ctl-Alt-Delete gets some users to a usable grub screen
  2. If you have an Nvidia Optimus card you should NOT install nvidia drivers, just use the built in driver, see here:

  3. After selecting boot options you have the opportunity to edit the boot flags manually using your keyboard. Replace quiet splash with no splash to get an idea of what step your system is failing at. Using that information search the forums or the internet for answers from the community.

  4. If you still can't install Ubuntu then unfortunately you've probably run into a hardware specific bug, please see here: How do I report a bug?

share|improve this answer
2  
Incase it helps anybody, if you're using a USB stick, be sure you actually burn the ISO onto the stick and not just copy it :) I used Universal USB Installer –  n00b Feb 12 '13 at 2:49
1  
+1 You would have thought that Ubuntu would boot into nomodset by default, like Windows boots with Standard VGA driver by default. Still far from a user-friendly install, but thanks to this I got past my black screens (two of them, USB installer, and once installed for Nvidia drivers). #Fail –  eduncan911 Jan 13 at 22:04
    
Had this problem with plain Debian too, but nomodeset fixed it! Thank you –  Tobia Apr 20 at 21:24
    
I love Ubuntu and use it every day, but when a major version upgrade on a laptop with one of the commonest graphics and mobo chipsets in the world leaves you at a situation with a black screen and blanking cursor that probably only a reinstall from a live CD will fix, it makes me wonder why people think it will displace Windows any time soon. Why do I have to choose between crap graphics performance or a proprietary driver that will wreck an install when an upgrade happens? –  Alan B May 1 at 8:23

If an update or something else caused your boot problem:

  1. Freezes:

  2. nVidia Users:

  3. ATI/AMD Users:

  4. Grub recovery cross links

  5. Reinstalling your machine

  6. Sometimes a kernel upgrade can cause problems, especially if you're using closed drivers, you can confirm if this is the case by booting into your old kernel.

  7. LiveCD recovery crosslinks

  8. and so on ...
  9. If you still can't boot Ubuntu then unfortunately you've probably run into some other kind of bug, please see here: How do I report a bug?
share|improve this answer

If your system is dual boot:

Link up the following:

share|improve this answer

If your graphics card is Nvidia, follow these steps:

  1. In the GRUB menu at startup, press e; then,
  2. Use the arrow keys to replace quiet splash with no splash or nomodeset.
  3. Then press the Ctrl+x key combination to boot.

If your graphics card is ATI, follow these steps:

  1. In the GRUB menu at startup, press "e"; then
  2. Use the arrow keys to replace quiet splash with radeon.modeset=0.
  3. Then press the Ctrl+x key combination to boot.
share|improve this answer

Increase screen brightness

On certain laptops(like HP pavilion),you may boot to black screen due to low screen brightness.

Increase the brightness using key combination(The key differs for every model. For eg FN+F7)

share|improve this answer
    
OMG! What a relief! Thanks for the answer. It was really a silly problem. I spent hours in searching for the solution and found it here. It was just to increase screen brightness. In my case it's 'Fn + F8'. –  Mukesh Chapagain May 10 '13 at 2:37
1  
Confirmed on Dell XPS 12. Thanks you! I would have never suspected that. –  sparebytes Sep 5 '13 at 0:51
    
Confirmed on Lenovo Yoga 2 Pro. –  capdragon Apr 4 at 2:21

I had this problem last night. All of a sudden my system wouldn't boot up anymore. BIOS check would finish, then it would just hang there on a black screen with the cursor flashing. Left it there for several hours just in case. When that didn't work, I unplugged all my USB devices and all of a sudden it booted up fine again. I haven't narrowed it down exactly, but in my case it was either my USB hub or the iPod plugged into that USB hub that was causing it to hang.

Not saying this is necessarily the problem you're having, but hope your boot problem is as easy to fix as unplugging some USB devices...!

share|improve this answer
    
I have had this mystery solution as well. I think it was looking for a boot partition from some USB devices and it wasn't finding it, or was trying to read and getting hung. –  e.m.fields Oct 13 '10 at 6:21
    
The only thing I had plugged into a USB port was my mouse. I tried your solution, but unfortunately had no luck. –  Doughy Oct 13 '10 at 15:49
    
I remember this solution from Windows: I suspect your computer might have been trying to boot from one of those USB devices, and didn't do anything because they couldn't really boot. Changing the boot order in BIOS might allow you to boot normally with USB devices anyway. –  JMCF125 Feb 12 at 11:07

If you are using the Windows Installer (Wubi)

Wubi overrides are identical to normal installs except the first time you reboot after running the installer in Windows.

To complicate things, since Ubuntu 11.10 there are two distinct methods to install with Wubi. The first way is using the Desktop ISO, which applies to all sub-flavours (Kubuntu, Lubuntu, Mythbuntu etc.) and also if you downloaded the Ubuntu ISO yourself.

The second method is using a pre-installed disk-image, if you run wubi.exe standalone and choose to install Ubuntu.

Method 1

You'll see this:

Completing the Ubuntu installation
For more installation options, press ESC now 5...4...3...2...1

Press Esc and then you see this:

Normal mode
Safe graphic mode
ACPI workarounds
Verbose mode
Demo mode

Ignore Safe graphic mode as it applied to Ubuntu in 2008 and does nothing for the modern nvidia/radeon issue. Place your cursor on Normal mode and press E. Then edit the entry and insert nomodeset as shown here (look for it between noprompt and quiet splash in the middle; note there may be some other differences but don't change anything else - just add nomodeset):

linux /ubuntu/install/boot/vmlinuz debian-installer/custom-installation=/ubuntu/install/custom-installation 
iso-scan/filename=/ubuntu/install/installation.iso 
automatic-ubiquity noprompt nomodeset quiet splash boot=casper ro debian-installer/locale=en_US.UTF-8 
console-setup/layoutcode=us console-setup/variantcode= -- rootflags-syncio
initrd /ubuntu/install/boot/initrd.lz

Now press Ctrl+X to boot.

NOTE: This only applies to the Installation; the next time you boot you have to override it again, and for this it will be the same as for a normal install (answered above). Make sure you hold Shift to make the Grub menu show though.

Method 2 When you run wubi.exe standalone and install Ubuntu (not a sub-flavour), it downloads a pre-installed, compressed disk image with a default Ubuntu install, and then decompresses this to the size of the virtual disk. There is no grub.cfg setup yet so it uses the file \ubuntu\install\wubildr-disk.cfg for the first boot which you can edit and add nomodeset:

loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
search --set=diskroot -f -n /ubuntu/disks/root.disk
probe --set=diskuuid -u $diskroot
linux /vmlinuz root=UUID=$diskuuid loop=/ubuntu/disks/root.disk preseed/file=/ubuntu/install/preseed.cfg wubi-diskimage ro quiet splash nomodeset
initrd /initrd.img
boot

Note - if you've come to this thread after booting for the first time, it's possible that the grub.cfg has already been created (even if it froze up). In this case, editing the \ubuntu\install\wubildr-disk.cfg file will do nothing - it always checks for /boot/grub/grub.cfg inside the virtual disk first. So you should follow the instructions for the normal install above.

Note also that the Grub Menu is suppressed by default on Wubi installs (even though there are two operating systems - because you boot Ubuntu from Windows, and therefore adding a Windows entry from Ubuntu's Grub Menu makes no sense) so you have to press and hold the Shift key after selecting Ubuntu in order to display the Grub Menu. On Windows 8, it reboots after you elect to boot into Wubi, in which case, you should hold the Shift key after the BIOS posts.
(This is only for Windows 8 with BIOS - Wubi doesn't work with UEFI).

share|improve this answer

I also had this problem, or a similar one. It turned out that, for some reason, Ubuntu had started with the screen brightness on its lowest setting. If I went into a very dark room, I could see the screen just well enough to go to the "Brightness and Lock" control panel and turn the brightness up to where it should be.

share|improve this answer

It appears as we both share the same hardware. At least the same CPU, The same P67 and the same video card (Mine is a GT 440). What you can do is the following:

  1. When booting press the ESC Key or leave the SHIFT key pressed until the GRUB menu appears.

  2. In the GRUB menu select the RECOVERY MODE. It should say something like:

    Ubuntu, with Linux 3.2.0-25-generic-pae (recovery mode)

  3. After the recovery mode finishes loading, it should present you with a menu. Select the option about going to the shell with root access (root Option. Last option in the image below)

    enter image description here

  4. Now we need to install the Nvidia drivers and update the system. Follow the next lines step by step to do this in the correct order. Also make sure you are connected to the Internet:

    A. Updating System

    1. sudo apt-get update
    2. sudo apt-get upgrade

    B. Nvidia Drivers

    There are 2 ways to install the Proprietary Drivers. the PPA Way or the Default Ubuntu way.

    1. The Default Ubuntu Way involves just typing in the terminal sudo apt-get install nvidia-current (For the current normal drivers) or sudo apt-get install nvidia-current-updates (For the latest current drivers). Just pick one.

    2. the PPA way has the Latest bleeding bloody edge drivers. I mention this one since I am testing it in some use cases that relate to problems using TVs and 16:9/16:10 resolutions. To install this one do this:

      sudo add-apt-repository ppa:ubuntu-x-swat/x-updates and press ENTER to accept a message you will receive. Then do sudo apt-get update. Lastly do sudo apt-get install nvidia-current. Note that you can not mix this one with the Ubuntu way. One will overwrite the other one.

  5. Reboot sudo reboot

Now if you happen to have any problems do the following via the terminal again but this time go to your home folder. In my case it is /home/cyrex, so I would cd /home/cyrex. In your case you should change that to your user and the apply the following:

sudo rm -fr ./config/monitors.xml
sudo rm -fr .nv*
sudo rm -fr /etc/X11/xorg.conf

Then when you boot into Ubuntu change the resolution via the Displays option in the Ubuntu Settings Menu (The cog in the upper right corner)

What we did there was remove the monitors.xml to solve some resolution problems, remove the .nvidia-settings to fix some Nvidia config problems and remove the xorg.conf (Which is not really needed in the latest Ubuntu versions) to remove any badly configured options.

Lastly we can execute the grub option in the recovery menu to fix any bootloader issues.

share|improve this answer
1  
Thanks! Mine had been booting into a black screen. I didn't follow most of what's here, but I found a way to enter recovery mode since the shift method didn't work for me. In the end, the fix was a grub update in recovery mode. –  kelvinilla Jul 31 at 17:37

how to fix :

  1. Start ubuntu, login, now in the blackscreen go to the console ctrl-alt-f1 and type nautilus

  2. if nautilus cannot be opened in terminal type unity

  3. now without exiting or stoping the unity comand return to the ubuntu interface in my pc is ctrl-alt-f7
  4. open terminal in nautilus using ctrl-alt-t and type nautilus
  5. while nautilus still open, in terminal type sudo software-properties-gtk
  6. search for graphic drivers, my problem was the default drivers of X.org. I have an ati video card and I installed the drivers of fglrx-updates if you have nvidia install the drivers of nvidia or if you have ati driver
  7. reboot
  8. after login u will see nautilus running well and the wallpaper the only thing not working is unity. open terminal and type: dconf reset -f /org/compiz/ and setsid unity

thats it.

I hope this fix your problem.

share|improve this answer

I upgraded from 10.10 to 11.04 to 12.04 LTS, and when 12.04 loaded for the first time, I had a blank screen after the GRUB menu. It actually booted fine - I could SSH into the system as usual, but the video at the actual console didn't work. Booting into recovery mode worked fine, too. Here was the solution.

Hardware = Macbook, early 2008, Macbook4,1. (Black - Early 2008/Penryn)

After much trial and error, the solution was the editing and updating GRUB as shown below. The relevant edits were

  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
  • GRUB_GFXMODE=1024x768

sudo nano /etc/defaults/grub
sudo update-grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX="nopat"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
share|improve this answer

If you have more than one video port on your graphics card (or more than one graphics card), then plugging the monitor into a different port may fix the problem.

I've had an issue in the past with dual-DVI graphic cards, where it won't boot using one of the ports (secondary maybe?), but works fine on the other port.

share|improve this answer
1  
I disabled the on-board graphics to fix this problem –  Rots Jun 30 at 10:24

If Ubuntu 10.04 booted, but not 10.10 or newer versions booted

Chances are your computer's ACPI is not supported. Ubuntu 10.04 supported drivers for the ACPI, but dropped supported for that since 10.10.

To try that, change the BootOptions to nolapic and see if the Ubuntu Live CD boots (info).


If it worked, you have 2 options to make the LiveCD boot:

  1. Disable the "New Card Interface" (which I saw the method in UbuntuForums)

    • Go to BIOS > Security> I/O interface Security> "New interface card". Set it to Locked.

    • Make sure you have a Windows Recovery CD available if you have Windows, because Windows may show up as an error.

  2. Or, disabling the ACPI, which is not recommended because it may disable some crucial features on you computer (like fans). This is not recommended unless you have tried the first option and you know what you are doing!

    Instructions (source):

    • Restart your computer.

    • Press the key indicated during the startup messages (usually F2, Esc, or F1) to enter BIOS.

    • Click on the "Power Settings" menu.

    • Highlight the ACPI entry, press Enter, select "Disabled" and press Enter again.

    • Press Esc and Y to exit and save.

    • Again, make sure you have a Windows Recovery CD available if you have Windows, because Windows may show up as an error.

Different PC manufacturers have different BIOSes, so read your computer's manual if your computer's BIOS doesn't show up.

share|improve this answer

I have had this problem a few times. I occasionally get errors detecting one of the HDDs, and I think the boot order gets corrupted in the BIOS. Fixing the boot order solves the boot problem. I have an old Nov 2005 ASUS mobo with a 750 GB WD and a 1.5TB Samsung hard disk.

share|improve this answer

I had this issue with Ubuntu 12.04 64bit version. I install all goes well, I enable the Nvidia drivers reboot and nothing but a black screen. I re-installed several times with the same results. I then remembered that I had this problem with previous versions of Ubuntu. I downloaded and installed the 32bit version then installed the Nvidia drivers and I did not have this issue. It only happens when I use the 64bit version with the Nvidia drivers.

share|improve this answer

On my notebook I had funny problem. I thought I had black screen two times and I had to shut down it with button. Shortly before I tried again and I barely saw some dark letters in the center of the screen so I pressed the button which brightens up the screen and now it works :)
Also, I've used http://sourceforge.net/projects/unetbootin/, maybe it helped.

share|improve this answer

Turns out I had to create a LiveCD and completely reinstall GRUB. After I did this, things are working fine again.

Documentation for re-installing grub is here : help.ubuntu.com.

share|improve this answer
1  
to reinstall grub, the documentation is here help.ubuntu.com/community/Grub2#ChRoot –  stivlo Apr 12 '12 at 10:43

This one helped at least a bit: http://ubuntuforums.org/showpost.php?p=9965194&postcount=8

In summary:

  1. Run gksu gedit /etc/initramfs-tools/conf.d/splash.
  2. In the text editor, add FRAMEBUFFER=y to the file.
  3. Save the file and quit the text editor.
  4. Run (in a Terminal): sudo update-initramfs -u
share|improve this answer

I realize this is an old question, but it's also pretty general without any details about the specific hardware involved. That said, you can't file a bug or go about fixing things until you figure out some more details.

I thought I'd take a stab at this since I faced the issue and recovered from it pretty recently. I'll probably run through here again later and throw in some more info and simplify the steps, but the answer list is already pretty big, so I'll go easy on the screenshots.

Recovery mode is your friend, but you don't always need a single-user root session to solve things. In fact, you might just be able to do a normal console login by selecting "resume" without considering any of the other options on the recovery menu. The nice thing about a normal console session over the single-user root mode is that you can get multiple terminals running at once--Switch between them or open up new ones with Alt+F1, Alt+F2, etc. There's a good chance that it's a video driver issue which is preventing you from going into the graphical login, and it might just be a result of some upgrade you did before rebooting the computer.

You might go a couple of years at a time without experiencing similar issues, but it's a good idea to know your hardware and to be prepared to use the terminal. Basically there are two video drivers to worry about: the kernel driver and the xorg driver. Xorg is a video server that uses the x11 protocol to display things in full color with depth and all kinds of crazy effects--It's an abstraction layer between applications like the desktop environment or windowing managers and the kernel driver. The kernel driver is yet another abstraction layer, but it's a bit closer to communicating with the actual hardware.

It's the kernel's job (in this case, Linux) to pass messages between applications and the hardware. The drivers can either be compiled into the kernel or added in a more ad hoc way through kernel modules. Probably you're using modules unless you configured and compiled your own custom kernel. The kernel driver as a module gets loaded shortly after you boot up, which allows for easier upgrades when you power down to swap out a card. The good news is that there are some more or less standard tools that you can run from the command line to give you more information about those kinds of drivers, the actual hardware and whether they're loading: lspci, dmidecode and dmesg, to name a few. There are man pages (e.g., $man dmidecode) and many howtos on those kinds of tools, so I won't go into too much detail here for now.

Then there are the xorg drivers. To list what's available in the repositories, you might type apt-cache search xserver-xorg-video | less to give you a list of all possible drivers. Piping it to less with the '|' symbol which you can probably type by tapping the slash key while holding down shift (to be clear on what symbol this is), gives you the option to scroll back and forth through the list of drivers (with the arrow keys). To get more info on a specific driver, you might type apt-cache show xserver-xorg-video-vesa (to pick one at random). To install one, you could type apt-get install xserver-xorg-video-vesa and hope for the best. As of I don't know how many versions ago Xorg will try to load one of the installed drivers for you automatically, but under certain conditions you might have a configuration file lingering around in /etc/X11 called xorg.conf. So take a look and see if there's one there: ls /etc/X11/xorg.conf

If you upgraded an Xorg driver without directly upgrading Xorg itself, there's a chance that reverting to the old driver via apt-get install will not automatically pull in the version of Xorg that it's compatible with--It should but apt doesn't always do what it should. Minimally, you'll need a matching version of xserver-xorg-core. Don't bother with uninstalling the upgraded xorg replacement though, just enter the command apt-get install xserver-xorg-core to revert back and uninstall the newer version automatically. This advice applies mostly to transitional renamed packages which provide virtual packages to replace ones that are still being maintained in the same branch of the package tree. Virtual packages are sometimes a mess and can do funny things with any of a number of dependencies which are getting swapped around in the upgrade/downgrade process, but concentrate on getting back to the GUI first.

Now that I've given an overview of some directions to start with troubleshooting, let's get back to the console screen that you hopefully pulled off without a hitch from choosing "resume" at the recovery menu. It's a pain to be stuck without a mouse at the console when you've got a lot of copying and pasting to do, so prepare yourself with some gpm for mouse support and some other tools: links/links2 or w3m (web browsers), vim (text editor), dpkg, apt, less (vim style keys and searching like man), and grep. I'm probably leaving a few out.

Some particularly useful commands for dpkg are dpkg -L to show files for packages that are already installed and dpkg -l | less to show all packages which are currently installed (piped to less).Sometimes gpm is a little finicky about letting you select things, so you can restart it with /etc/init.d/gpm restart but you might have problems with clicking on links in a page before you restart w3m or the browser links. w3m is a little easier to scroll around and generally better for authenticated sessions (e.g., logging into forums for help). It takes a bit of getting used to hitting the Esc key to click on links (the hyperlinks) though, and the learning curve is a bit steeper than with the browser known as links.

Unless you've got an Nvidia card or something with proprietary driver support for linux that you want to try, I'd shy away from kernel drivers before trying things with xorg--Try troubleshooting the xorg drivers first because it can be a lot easier than customizing a kernel for hardware (depending on the brand). The thing is that you might wind up following a series of links that lead you in the wrong direction, with chip makers sending you to the card makers and card makers giving you no support. As for trying out different kernels for different "vanilla" versions of the driver, stick with kernel versions that aren't far off from your current one (given by uname -r) unless you're really interested in testing. There's a pretty good chance that the latest mainstream kernel won't even boot up on your system, so why bother if you're stuck with a half-way broken setup? Keep focused on doing the bare minimum that it takes to get back up again so you're not falling behind on too much work. You can type things up in emacs, vim or pico/nano or check your email in mutt or pine, but eventually you'll want to come back to the 21st century.

Good luck!

share|improve this answer

I had the same problem.

I just fixed it. (kind of) My solution (so you can boot back to GUI) (don't know if it really was this or it was a lot of thing together):

after that I could reboot and login.

OPTIONAL: if you have login loop (type password and is accepted it will re-ask it): (make backup of file)
mv ~/.Xauthority ~/.Xauthority.old and retry to login.

any question, just ask.

share|improve this answer
    
For me, first using "update grub loader" from recovery menu, removing fglrx driversm, installing `gdm`` and installing open-source drivers worked, though log in screen looks different. –  Rafal Aug 5 at 20:29

When the grub boot menu comes up, press e to edit the correct boot line. Where it says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" change this to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset".

If this works, then you can install proprietary graphics drivers which should get you going again.

If you have trouble with the above, you can change the above line permanently in the grub configuration file.

Boot into recovery mode (selection from the grub boot loader) and edit the file /etc/default/grub as per the above instructions.

You can edit this file by typing:

nano /etc/default/grub

You'll have to update the grub menu:

update-grub

then reboot by typing

reboot
share|improve this answer

UBUNTU 12.04 LTS install Problem, stuck/crash at loading screen. (Nvidia Graphics Cards)

  1. Remove Graphics Card from your machine.
  2. Install Ubuntu (You shouldn't get any errors when running generic driver.)
  3. After Ubuntu is installed then put graphics card back into machine while the tower still powered off. Then swap your VGA/HDMI/DVI cables to the graphics card. Turn on computer and select the recovery option from the GRUB menu then boot normally.

  4. Go to Nvidia website and grab the linux driver it will come in .run format

  5. Install Driver using the following steps.

    a. Move the driver to the desktop and rename it something simple and easy to remember.

    b. Ctrl+Alt+F1

    c. Run command sudo /etc/init.d/lightdm stop

    d. Run command cd ~/Desktop DRIVERNAME.run (What you renamed it.)

    e. Run command chmod +x DRIVERNAME.run

    f. Run command sudo ./DRIVERNAME.run

    g. Follow instructions and continue

    TIP If you still get hung with "It appears you are running "X" server then change the command on Step 5c to as follows: sudo /etc/init.d/gdm stop

  6. Ctrl+Alt+F7

  7. Ctrl+Alt+t (Only use steps 7 & 8 if you can't access the restart button or see your screen.)

  8. Run the command Shutdown -h (OR sudo shutdown 0 -h if the other command fails.)

  9. Boot computer and enjoy :) I suggest printing these instructions.

PS I am not sure if you can place graphics card into PC after installation this is the way it worked for me and I am passing it on. I might suggest trying to install the graphics card on step 1 with machine off first as it is much safer this way.

share|improve this answer

In case that the black screen is only intermittent (and that there might be a blinking cursor), lightgdm having a race condition and not being able to start properly could be the issue.

At least that was the case for me. See here for a solution: http://www.webupd8.org/2013/01/ubuntu-lightdm-black-screen-when-using.html (see also this bug report).

The gist of it: Use gdm and not lightgdm (i.e. sudo apt-get install gdm, and choose gdm as default login manager when asked).

Let me quickly describe the symptoms I had: At first, because also the graphics was having a problem, when this problem occurred, I would only see a blank screen, and no chance to switch to the other terminals by pressing Ctrl+Alt+F1-6 (the screen simply stayed completely black, or rather, a very dark purple or something).

This I fixed by adding the "nomodeset" kernel option, as stated e.g. in this answer.

But after that, I still intermittently couldn't boot up properly; now it would stop with a blinking cursor. And this, as the above link tells in more detail, is caused by lightdm having a race condition - which manifests itself mainly if the boot-up is very quick, e.g. from an SSD (as it is the case for me).

Hope this helps someone.

share|improve this answer

I tried those methods as well -- no joy. Here's what did worked for me.

Here's the part that was useful:

Getting 1366x768 resolution

Create file /etc/grub.d/01_915resolution

echo insmod 915resolution
echo 915resolution 58 1366 768 32

and execute:

chmod +x /etc/grub.d/01_915resolution

In file /etc/default/grub, assign value 1366x768x32 to variables GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX:

GRUB_GFXMODE=1366x768x32
GRUB_GFXPAYLOAD_LINUX=1366x768x32

Execute:

sudo update-grub

reboot, now you have 1366x768 resolution.


Actually, I already had this resolution. But the added commands got rid of the black screen on boot-up and the need to switch video modes.

share|improve this answer

If you installed from a USB drive, check whether it boots with the flash drive plugged in and if so, this may help.

share|improve this answer

This is specific to where the install fails and your installation behaves badly.

Requeriments

  • You need access to the Recovery menu, if you don't then look for other options.
  • Internet access with a DHCP-enabled network
  • GUTS! Since this is a delicate process.

Procedure

  1. Once you are in the recovery menu, select Activate Networking.
  2. Now select drop to a root shell.
  3. Run mount -a. (In my case that bad was the installation that I was forced to do this)
  4. Verify that your network is up and running: ping -c 2 4.2.2.2 If this fails run dhclient. ping -c google.com if this fails run dhclient.
  5. Now update your repositories: apt-get update
  6. Install debsums: apt-get install debsums
  7. Run debsums -s. It will give you a list of packages that have problems. Take note of each.
  8. Now reinstall the packages that has problems: apt-get --reinstall install packages.
  9. Update your grub just in case. update-grub.
  10. Reboot and good luck.
share|improve this answer

I just had a similar issue with Xubuntu after installing ATI catalyst drivers. Purging the 2 fglrx packages allowed me to log in properly and have a desktop....though without the proper drivers and acceleration.

share|improve this answer

It turns out the ATI Catalyst drivers were not compatible with the 13.10. I ended up re-installing the OS from the live CD and everything went fine, except now I have to figure out why there is no sound.

share|improve this answer

After upgrading from 12.10 to 13.04, the login screen is black because brightness is set to lowest level (Intel Integrated Graphics)

I've noticed that it would be a brightness problem cause I've listened to the Ubuntu's default drum sound when booting for the first time after upgrading. Before I find this solution, I had to increase the brightness level to see anything on the screen.

For me, the solution came from this bug report at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1173059, by changing /etc/default/grub as root this way:

Make a backup file, so you'll be able to restore it, if this solution doesn't work:

sudo cp /etc/default/grub /etc/default/grub.original

To open the file with sudo you can use this in the Terminal, for example:

sudo gedit /etc/default/grub

Then, replace:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

You'll need to run update-grub2 to apply the change:

sudo update-grub2

That's it. After rebooting, it worked flawlessly for me (that is, my login screen has a normal brightness level).

share|improve this answer

protected by Community Apr 28 '13 at 20:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.