Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

SOLVED

I'm trying to install Kubuntu alogng with the preinstalled Windows 7.

I boot from CD Create three partititons: / (ext4), swap and a 100MB reserved bios

All installs correctly, but I'm not able to boot Kubuntu

From the bios setup disappeared the option to use legacy bios instead of UEFI (or at least I cannot find it)

I have the option to create a new boot entry, but I don't know what to type in.

What can I do?

Thanks Mirto

=========== added 10 Lug 18:54 ========================

Seems relate to bug 972122 ( https : // bugs.launchpad.net/ubuntu/+source/partman-efi/+bug/972122 ) The message I saw when the EFI boot partition was missing is the same reported in https : // launchpadlibrarian.net/99750202/EFI-warning.jpg

The bug is marked as fixed-released What I'm missing?

There is any particular install CD using partman-efi?

============== added 12 Lug 18:27 =========================

I've tried boot-repair using a ubuntu-secure-remix - I updated boot-repair before using it.

I've sent the error output posted at http://paste.ubuntu.com/1088164/ to boot.repair@gmail com

Boot-repair is suggesting other actions and I'll try

============= added 12 Lug 19:23 ==========================

Second try: non luck log at http://paste.ubuntu.com/1088300/

============= added 13 Lug 18:05 ==========================

At power-on magically the ubuntu boot entry appeared

Boot-repair was the solution

share|improve this question
    
If this question is solved, do an upvote to the answerer and accept that answer. If you solved the question, then write an answer yourself and accept that. This is the equivalent of putting [SOLVED] word at the title. Thanks –  Anwar Shah Jul 13 '12 at 16:18
add comment

1 Answer

up vote 3 down vote accepted

Your disk is GPT-type, so you need either an EFI or a BIOS-boot partition. Run Boot-Repair, update it, and click Recommended Repair. Note the URL that will appear. Reboot and check if your problem is solved. Indicate the URL if not.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.