Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm compiling ardour3 from source and as far as I can tell I have all the libraries mentioned in http://ardour.org/building_ardour3

Unfortunately running ./waf configure gives the following error

Checking for 'lv2' >= 1.0.0                          : not found

I have the following packages installed that look useful but don't seem to help:

i   lv2-c++-tools                   - library and tools for LV2 plugins         
i   lv2-extensions-good             - LV2 extensions from the "good" set        
i A lv2core                         - LV2 audio plugin specification            
i   lv2fil                          - Stereo and mono LV2 plugins, four-band par
i   lv2file                         - Command-line program to apply LV2 effects 
i   lv2proc                         - command line effect processor             
i   lv2vocoder                      - LV2 vocoder plugin 

Where can I find that library. I'm okay with compiling it myself.

Apparently there is a package in SID: http://packages.debian.org/sid/lv2-dev I'll try getting that in a while

The source code can be had via subversion:

svn co http://subversion.ardour.org/svn/ardour2/branches/3.0

share|improve this question
    
Nate: please see edited answer for a working solution. It appears ardour wants the latest versions which must be built from source. –  izx Jul 11 '12 at 20:21
add comment

1 Answer

up vote 3 down vote accepted

Ardour wants the latest unified version of lv2, which was only released on April 18, 2012, and is not available in any repositories yet. You must download and build it from source:

  1. Download http://lv2plug.in/spec/lv2-1.0.0.tar.bz2, extract and enter source directory.
  2. ./waf configure && ./waf build && sudo ./waf install should do the trick.

waf for Ardour will then also ask you for the latest versions of the following dependencies, which you can download from the below URLs and build/install as above. Note that the drobilla.net server is sometimes offline, in which case just google the filenames and you will get alternative download servers.

  1. http://download.drobilla.net/serd-0.14.0.tar.bz2
  2. http://download.drobilla.net/sord-0.8.0.tar.bz2
  3. http://download.drobilla.net/sratom-0.2.0.tar.bz2
  4. http://download.drobilla.net/lilv-0.14.2.tar.bz2
  5. http://download.drobilla.net/suil-0.6.4.tar.bz2
share|improve this answer
    
I already had all of these installed except lv2proc. Adding it didn't improve the situation. I'm editing my original post to contain this info. –  Nate Iverson Jul 10 '12 at 15:47
    
@NateIverson: please post a direct link to the source. –  izx Jul 10 '12 at 15:58
    
@ I got the link through subversion I'll edit it into the original post –  Nate Iverson Jul 11 '12 at 3:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.