Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
What should I do when Ubuntu freezes?

Have been looking everywhere to find a solution to this problem but have yet to find a solution. I am running 64 bit 12.04 LTS on a AMD C-50 Dual core 6 gigs ram AMD Ratheon HD 6250.

The problem I am experiencing is when ubuntu gets to the wallpaper screen it will sometimes freeze soon after the the image appears or shortly there after gnome loads locking up keyboard and mouse. When I try to log in via the console the same thing happens (this is as ubuntu is loading).

At the moment the system is set to auto login previously it was set to ask for password but it did the same thing. Switching to from lightdm to gdm did nothing to alleviate the issue.

I have never had so many issues with ubuntu I have to say 12.04 is the most buggy version yet.

share|improve this question

marked as duplicate by Jorge Castro, Bruno Pereira Jul 20 '12 at 8:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
How long does that show up? –  hexafraction Jul 10 '12 at 16:15
    
Well it does not seem to be a display issue. Log file shows system halts when it starts looking for a wifi connection. –  Frank Jul 18 '12 at 19:19
    
Are you using third-party WiFi drivers? –  hexafraction Jul 18 '12 at 19:20

2 Answers 2

up vote 0 down vote accepted

I discovered the real problem. It was AMD Catalyst. I have removed it since I have no need for 3d graphics on my system. There is another solution however it is found here.

http://www.upubuntu.com/2012/06/install-amd-ati-catalyst-126-display.htmlenter link description here

I tried this but I ended up with a watermark saying unsupported hardware. I was unable to remove it so instead I removed catalyst completely.

To fix the resolution problem I simply edited my xorg.conf file and added the right resolution for my monitors. Have not had it freeze since doing this.

share|improve this answer

I experienced a very similar problem. You may be having a problem where Compiz is incompatible with your graphics driver. Compiz is not needed to get to the login screen so you get to that point OK. Then when you login, Compiz loads (or tries to) and blows up. There are lots of tips on this site regarding how to fix broken Compiz, none of which worked for me and several of which bricked the PC completely. A possible workaround (not the solution) is to try and load the legacy Unity 2D desktop rather than the newer Unity 3D desktop (which is a Compiz plugin and hence rides on top of Compiz. To do this, boot the computer so you see the login display. If you configured auto-login, you need to figure out how to disable this. I ended up completely repeating the install process from scratch and when prompted whether to auto-login or not I selected no. At the login screen, there is a Ubuntu icon immediately to the right of your login ID. Click this and you'll see an option for desktop options: Unity (the new Compiz-based version) and Unity 2D (the old Compiz-free version). Select Unity 2D and then click Back and then finish logging in. When you log into your desktop, lightDM will not try to load Compiz at all. If your desktop then loads fine, you at least have a functioning system and know where the problem is, even if you are missing a bit of bling.

Running the command echo $DESKTOP_SESSION in a shell will tell you whether you are currently running Unity (3D/Compiz) or Unity 2D (no Compiz).

To make permanent your decision to use Unity 2D, run gksu gedit /etc/lightdm/lightdm.conf and change user-session=ubuntu to user-session=ubuntu-2d. Save, exit gedit and reboot. You should not have to manually select Unity 2D vs. Unity 3D at login as lightdm will read its config file and automatically load Unity 2D. Good luck.

share|improve this answer
    
The OP cannot even get to the logon screen, and this happens during installation. Therefor, using Ubuntu 2D does not help the situation at all. –  hexafraction Jul 10 '12 at 16:16
    
@user76098 Well so far so good.... seems it was compiz causing the problem! I can now get back to work using ubuntu. I don't really care about the glitz so I can do without I just need my system to work. I was tired of using windows! Thanks again –  Frank Jul 10 '12 at 17:55
    
Well looks like this did not resolve the issue. Still freezing, except now it's freezing at the login screen, this is after I set lightdm.conf settings as you suggested.Any other thoughts? –  Frank Jul 11 '12 at 14:25
    
Well I guess it's back to Windows for me... Ubuntu is completely unusable for me. Or I may try a different linux distro. –  Frank Jul 11 '12 at 19:59
    
Have discovered that Ubuntu runs fine with my dual monitor set up at home but when I use it at work with the company monitor it freezes. My logs show nothing when the system freezes so there is nothing I can post. Still frustrated by this annoying bug. –  Frank Jul 13 '12 at 5:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.