Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems that my knetworkmanager is not starting anymore. Read: In KDE4's sys tray I don't have a icon to manage my networks. Also when starting it from terminal or kick off menu literally "nothing" happens. I don't know what's wrong with it.
I tried to start it via Alt + F2 - also nothing. Maybe also worth to note that in the terminal no error occurs, the command return ready for the next input, not the slightest error message. ó_O?

Sadly after reading this answer on superuser.com it seems I can not connect to wifi via iwconfig 'cause my network is WPA2 encrypted. (Basically I can not set they passphrase -> invalid argumenterror.)

So it seems I've to get knetworkmanger running again as I also can't download other tools. I've tried stuff like

sudo service network-manager restart

but it didn't seem to help.

I'm kinda puzzled so any help for this would be appreciated.

PS: If it hasn't become clear: The whole drama of is simply I can't connect to wifi and internet :o)

Edit:
As suggested I tried to reinstall network-manager-kde* and it is pretty much the same except one difference: It said something about a something.so library.
Sadly I couldn't save the something because the usb flash drive is mounted as read only (another issue I have -sight-).
(It was a 2 liner and continued stating to switch back do some q-foo... default mode hence I reckon the manager has started up no visual reference (systray icon) ).

However, notice that upon observing this I have re-uninstalled and re-re-installed the network manager to see if I could reproduce the error but no luck. Haven't tried rebooting though as I'm downloading a new ubuntu image and properly just upgrade the full system after saving /home.

*If you run into the same situation: Need to install something without having network access: google the package name and download it from ubuntu make sure to select the right version though! In my case I got a .deb file which I simply copied on my usb stick and installed it on the system via double click in the file manager (doplhin in my case). So don't panic if you run into these troubles! :)

share|improve this question
    
Try just running knetworkmanager from (alt+f2) –  Thomas W. Jul 10 '12 at 15:50
    
Been there, done that. Just couldn't remember how it's called (dashboard?). However same effect as the other methods: mouse cursor indicates some background action but nothing is happening at all. –  yoshi Jul 10 '12 at 17:28
    
run it from the terminal, and see what errors (if any) are being output. –  Thomas W. Jul 10 '12 at 17:28
    
edited the question: no output. :C –  yoshi Jul 10 '12 at 17:33
    
For the heck of it, try installing network-manager-kde and see if this fixes it. that's network manager's KDE plasmawidget –  Thomas W. Jul 10 '12 at 17:33
show 2 more comments

1 Answer

I have the same problem with knetworkmanager. Tried reinstalling, but no success.

Here is the output from running knetworkmanager from cli:

$ knetworkmanager
knotify(15737) KNotify::event: 3  ref= 0
knetworkmanager(17694)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
knetworkmanager(17694)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_networkmanager07.so" does not offer a qt_plugin_instance function.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QSystemTrayIcon::setVisible: No Icon set

Running ps -ef | grep '[N]et':

~$ ps -ef | grep '[N]et'
root      1012     1  0 18:33 ?        00:00:00 NetworkManager

In the end I installed wicd and that is bringing up the wireless network:

~$ sudo apt-get install wicd wicd-cli wicd-curses wicd-daemon wicd-gtk

And it works flawlessly!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.