Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I performed a fresh install of Lubuntu 12.04 with minimal desktop, as described here.

To clarify, I did a command-line install from the Lubuntu alternative install disc, then I did an apt-get install --no-install-recommends lubuntu-desktop.

Everything is working fine, except that Synaptic will not run from the menu entry in the panel. I am not prompted for a password, and no window of any sort appears after clicking the menu entry. I installed lxshortcut to see what the shortcut was running, and the command is synaptic-pkexec. If I type this command into the "Run" menu, I get the same behavior (or lack thereof).

I can get Synaptic to open up just fine by typing gksudo synaptic at the "Run" menu. Also, if I run "synaptic-pkexec" from the terminal, then I am prompted for my password within the terminal, and after that Synaptic opens normally.

Can someone please suggest the right way to get Synaptic working? I could just change the menu entry to "gksudo synaptic", but I'm guessing that it's set to synaptic-pkexec for a reason. I have a vague understanding that this pkexec business has something to do with PolicyKit, but I don't really know what PolicyKit is or how to tell if something is broken with it.

share|improve this question
    
This was a bug in Ubuntu 11.10, same exact scenario... it's discussed here - ubuntuforums.org/showthread.php?t=1827093 Maybe running an update would resolve it? –  Corey Whitaker Jul 10 '12 at 14:20
    
Can you start synaptic from terminal ? If you can't , enter output in here. –  alireza.m Jul 10 '12 at 14:20
    
Thanks for the link. According to that thread, the bug was fixed in synaptic-0.75.2ubuntu6. Running "apt-cache policy synaptic" says I have 0.75.9ubuntu1 installed. "apt-get update && apt-get dist-upgrade" says I'm fully up to date. –  ven42 Jul 10 '12 at 15:05
    
Try re-installing Synaptic. –  tijybba Jul 10 '12 at 15:41
    
Just tried "apt-get install --reinstall synaptic". The process completed successfully, but it did not change the behavior of synaptic. The problem still exists, I'm afraid. –  ven42 Jul 10 '12 at 15:49
show 2 more comments

1 Answer

up vote 1 down vote accepted

It turns out that I needed to install the policykit-1-gnome package. Once I installed this package and rebooted, Synaptic worked normally.

I installed the complete Lubuntu desktop in a VM for comparison with my minimal installation, and that's how I discovered what was missing. According to the package description:

PolicyKit-gnome provides a D-Bus session bus service that is used to bring up authentication dialogs used for obtaining privileges.

Obviously, without the described functionality, I was never going to get a GUI authentication prompt to open Synaptic.

synaptic is a dependency of the lubuntu-desktop metapackage, so it was installed by default in my minimal installation. Shouldn't policykit-1-gnome be a dependency of lubuntu-desktop as well, since Synaptic won't work without it? Do you think I should report a bug?

share|improve this answer
    
Excellent work tracking down the cause of the problem! And yes, I think you should report this as a bug. My Lubuntu systems installed from the Lubuntu desktop CD don't have this problem; they probably come with policykit-1-gnome installed separately from any other packages. It's set to manually installed (and I didn't install it myself). If you report a bug, please update your answer with the bug link. –  Eliah Kagan Jul 12 '12 at 0:23
1  
I'm getting this exact same problem running a minimal install of ubuntu using standalone compiz session with Unity. Thing is, I have policykit-1-gnome installed, but its still not working. –  thelaststud Aug 17 '12 at 10:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.