Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what a function tooltip looks like for Eclipse CDT in Ubuntu 10.04 with the default theme:

black is the new black!

There's nothing in Eclipse's General > Appearance > Colors And Fonts preferences settings. Is there an easy fix for these unreadable context sensitive help boxes?

share|improve this question
    
Thanks for asking this. I experienced the same problem, but it never occured to me that this would just the place to find people solving that problem for me. :) –  Bananeweizen Aug 20 '10 at 19:38
3  
See bugs.launchpad.net/ubuntu/+source/light-themes/+bug/540332 (ubuntu bug report) and bugs.eclipse.org/bugs/show_bug.cgi?id=309907 (eclipse bug report). Both said this is fixed, but it doesn't work for me as of now. –  Elazar Leibovich Aug 26 '10 at 18:26
2  
There is a solution in this post too... askubuntu.com/questions/70599/… –  Chris Mancini Apr 27 '12 at 14:23
add comment

9 Answers 9

up vote 6 down vote accepted

This can be solve by changing the background colour in Ubuntu. I’ve tried changing the background colour in Eclipse but it doesn’t seems to works. To change the background colour in Ubuntu, go to

System > Preferences > Appearance

enter image description here

“Appearance Preferences” panel shows up, click on “Customize…”.

enter image description here

“Customize Theme” shows up, go to “Colors” and select a lighter color for “Tooltips” Background, a darker color for “Tooltips” Text.

enter image description here

Start or restart Eclipse, you will see the the lighter colors you selected when the code-assist appears.

This solution is copied from: http://tipstank.com/2010/05/23/solve-eclipse-black-pop-up-code-assist-box-in-ubuntu-10-4-lucid/

share|improve this answer
    
This may fix Eclipse, but it breaks tooltips in other applications. White on white tooltips for Firefox now! EDIT: aha - restarting seemed to sort Firefox out... I'll keep this setting, it's looking good so far. –  richq Aug 8 '10 at 19:48
    
This is a bug in Eclipse (bugs.eclipse.org/bugs/show_bug.cgi?id=319986), so I think there is no better solution to this problem at the moment –  lukasz Aug 8 '10 at 20:24
    
@richq in order not to break everything else, switch the whole theme to, say, "New Wave". –  Elazar Leibovich Aug 26 '10 at 18:07
1  
It would be great if you could copy the relevant instructions from that article and add them to your answer. That way, if the link breaks, we'll still have all of the important information. –  michaelms Feb 7 '12 at 1:47
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Peachy Nov 10 '12 at 12:03
add comment

Go to Window -> Preferences -> C/C++ -> Editor Under "Appereance color options" edit your "Source hover background"

share|improve this answer
add comment

I've solved using this tip: http://wiki.eclipse.org/IRC_FAQ#Black_background_color_for_tooltips_on_Linux.2FUbuntu.2FGTK

But I also changed the selected_fg_color to black. So I did change as follows:

tooltip_fg_color:#000000
selected_bg_color:#f07746
selected_fg_color:#000000

So just

sudo gedit /usr/share/themes/Radiance/gtk-2.0/gtkrc 

and insert in place of the first line:

gtk-color-scheme = "base_color:#ffffff\nfg_color:#4c4c4c\ntooltip_fg_color:#000000\nselected_bg_color:#f07746\nselected_fg_color:#000000\ntext_color:#3C3C3C\nbg_color:#E6E6FA\ntooltip_bg_color:#C0C0C0\nlink_color:#DD4814"
share|improve this answer
add comment

My solution: Set the tooltip background to a gray variety. Works for both white and black text!

share|improve this answer
add comment

Eclipse seems to take the tooltip backgroud color from the system theme.
I wasn't able to change the tooltip color without changing the system theme. I'm using the tropical theme with ambiance window decorations, currently, and it's working great! Give it a try!

share|improve this answer
add comment

Try to customize the used Ubuntu theme System > Preferences > Appearance > Customize In the tab Colors change the background and text colors of Tooltips

share|improve this answer
add comment

For CDT do the following:

Window>Preferences>C/C++>Editor: Appearance Color Options>Source Hover Background

Unfortunately there doesn't seem to be an application-wide setting. Kind of ridiculous.

share|improve this answer
add comment

An easy workaround to fix this is to install gnome-color-chooser. Open it, go to Specific -> Tooltips and put black foreground over pale yellow background.

share|improve this answer
add comment

I had the same problem with Zend Studio, it seems that the only fix at the moment is to adjust the tooltip colors in the appearance settings for ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.