Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed tuxonice on a Toshiba z830. I have ubuntu 12.04 (kernel was: 3.2.0-26) I wanted to be able to hibernate, which I consider to be a basic thing a OS should allow you to do. Well, it didn't work...but they already tell you it may not so I removed it. For doing all these I followed:

Problem with Hibernation

After uninstalling I switched off the laptop and after this I started to have several problems. The first one was that Cisco VPN didn't work anymore and then I realised that I could not even suspend my laptop. I found very strange that after removing tuxonice I still had this:

/lib/modules/3.2.0-26-generic-tuxonice/

The VPN problem could be solved by just copying from my previous kernel: 3.2.0-26-generic/CiscoVPN/ into the tuxonice one. Not very elegant but works.

Now, for the suspend problem (and the previous too) I can hold Shift when starting and select my old kernel and then suspend works again.

In my opinion tuxonice was not correctly uninstalled as it left that kernel behind and worse: ubuntu uses it if I do not take action. I have these work arounds....and here is my question:

how can I delete this tuxonice kernel safely? If you need more info please let me know.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Removing TuxOnIce

  • Start the terminal and enter:

     sudo apt-get --purge remove tuxonice-userui linux-generic-tuxonice linux-headers-generic-tuxonice
  • If you tried that, then try

     sudo apt-get --purge remove tuxonice\* 
  • Then restart

share|improve this answer
    
thank you for the prompt reply. I ran both commands but I still have the same problem. I still have the strange: /lib/modules/3.2.0-26-generic-tuxonice/ and I cannot suspend the computer. When I press the shift key when starting Ubuntu I still see the turnonice kernel and have to choose my previous one to get suspend working :-( –  Lluis Jul 10 '12 at 14:33
    
@Lluis: Can you run sudo update-grub please? Then reboot and see if you still get the tuxonice kernel in the list. –  izx Jul 10 '12 at 14:47
    
Victory! when I executed your two first commands I was doing something else and didn't realised that the second one didn't do anything. There was a typo spelling tuxonice. I realised this later and ran it again. Then your very last command with update-grub and it worked! thanks a lot! –  Lluis Jul 10 '12 at 14:55
    
@Lluis: sorry about the typo! Glad it worked, and hopefully hibernation gets officially restored sometime in the future... –  izx Jul 10 '12 at 14:58
    
thanks a lot. I also hope it works soon. It is very important for people using laptops as laptops. Until then I am happy I can suspend it :-) –  Lluis Jul 10 '12 at 15:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.