Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there are many posts like this, however none of the fixes I have found have worked.

I had the issue on 11.04, and after having no luck fixing it decided to try 12.04 however this has not fixed the problem. I'm using a Lenovo IdeaPad, the network card is a Atheros Communications AR9285.

edit add outputs:

sudo iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"NETGEAR-PLOW"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: E0:91:F5:7D:1B:BA   
          Bit Rate=65 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:77  Invalid misc:63   Missed beacon:0

eth0      no wireless extensions.

lspci -nnk | grep -iA2 net
06:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Subsystem: Lenovo Device [17aa:30a1]
    Kernel driver in use: ath9k
--
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
    Subsystem: Lenovo Device [17aa:392e]
    Kernel driver in use: r8169

Thanks

share|improve this question
    
You should add the usual outputs for troubleshooting a wireless problem to the question. As is, the question is rather vague. –  mikewhatever Jul 10 '12 at 17:28
    
What would these be? (I'm new to ubuntu/linux), The speed is just throttled to 1.5Mbits, when I should be getting 12Mbits, which I get with a cable. –  Luke Jul 11 '12 at 22:13
    
These two should be a good start: lspci -nnk | grep -iA2, sudo iwconfig. Please add the outputs to the question, or post them to pastebin.com. –  mikewhatever Jul 11 '12 at 23:38
    
I've added iwconfig, but lspci -nnk | grep -iA2 just returnedUsage: grep [OPTION]... PATTERN [FILE]... Try `grep --help' for more information. –  Luke Jul 12 '12 at 8:21
    
I am sorry, it should have been lspci -nnk | grep -iA2 net. –  mikewhatever Jul 12 '12 at 11:14

1 Answer 1

I found this to work!

http://www.jrhenkelmann.net/index.php?option=com_content&task=view&id=34

The tick box was not listed as "Pre-Released updates" but all boxes were ticked on the updates tab

share|improve this answer
    
Fix worked temporarily but now is back to slow speeds –  Luke Jul 24 '12 at 21:18
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Aug 3 '12 at 20:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.