Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 does not Shut Down at all and gets Stuck on 3 or 4 dots.

I am using a PC with Pentium 4 processor, 1.9GHz, 1GB RAM.

I tried using the command sudo shutdown now, but it gets stuck again at the Logo screen with dots.

And none of the answers seem to help me here. Please help with a gentler solution to shut down.

But restart works fine, the problem is only with shutting down.

share|improve this question
    
It seems to be a bug with Nvidia here, you can further refer solutions here askubuntu.com/questions/125844/… –  atenz Jul 10 '12 at 7:06
    
Thanks, just tried all the solutions but none of them are working. –  Ganesh.C Jul 10 '12 at 7:29
add comment

6 Answers 6

To shut down and power off from the command-line with shutdown, the correct command is actually:

sudo shutdown -P now

However, if that doesn't work, press Escape when you first see the splash screen with the dots. That should show the messages "behind" the splash screen. Then update your question (by editing it) with the full and exact text of the messages you see.

share|improve this answer
add comment

I have no idea what I did but its shutting down fine now in like 5 seconds.

Now these are the steps I followed as provided in the link by tijybba in the comment:

  1. Type in terminal: gksudo gedit /etc/default/grub
  2. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  3. Change this to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
  4. Save the file and close the file.
  5. Finally, in terminal: sudo update-grub

But again it didn't shut down properly.

Next I logged out of the OS (not shut down) and then from the login screen I shut down and it shut down.

Then I started my machine again and then shut down from GUI works fine now.

share|improve this answer
add comment

The correct command is sudo shutdown -h now. Try this. Hope it will help.

share|improve this answer
    
Thanks Anwar, but that's not working too. –  Ganesh.C Jul 10 '12 at 7:03
add comment

Why not to try

sudo poweroff now

shutdown is different. It will help you don't stop services and update your system (as an example)

share|improve this answer
    
I agree that sudo poweroff is a good way to shut down. (poweroff doesn't use now.) However, sudo poweroff and sudo shutdown -P now do the same thing (unless the system is in a very early stage of booting, or is already back down to single-user mode). See man poweroff and man shutdown. Both stop services and neither interferes with updates (beyond potentially canceling an in-progress update, which both can do and are equally likely to do). –  Eliah Kagan Jul 15 '12 at 17:01
    
@Eliah Kagan: Thanks, i will see man pages of both commands. I relied on my course teachers explaination when i wrote this answer. –  Hilmi Erdem KEREN Mar 31 '13 at 23:08
add comment

I updated the kernel to 3.5.0-4-generic and that solved my problem.

share|improve this answer
    
You may want to expand this answer to explain how to do that (or link to something that does), and also to cover the potential dangers of upgrading the kernel like this (so people who follow your advice are prepared). –  Eliah Kagan Jul 15 '12 at 16:59
add comment

it may also be a setting in your BIOS.. you can typically enter these settings when initially powering up the system and pressing F2 or F1 (The actual key may vary depending on manufacturer and year of the machine) check for "POWER" settings particularly something that may set the machine to wake on a network wake command... I have seen this interfere with Ubuntu's ability to properly shutdown.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.