Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is really simple:

I've replaced Thunar with Nautilus in my Xubuntu 12.04 installation (64 Bit); I removed Thunar completely. Everything works fine in the computer except for the desktop: If I try to delete a file that is in the desktop for example, The attempt fails complaining of Thunar not being installed on the system. If I reinstall thunar everything works as expected, but I don't want to keep thunar on the system. How to Fix This?

Thanks!

share|improve this question
    
perhaps you can explain how you replaced thunar with nautilus "completely" - need this information to see if we can reproduce your issue. Also - are you using nautilus to manage your desktop now? nautilus --no-desktop I think. –  fossfreedom Jul 10 '12 at 9:55
    
"sudo apt-get remove thunar && sudo apt-get install nautilus" that was what I did, everything went well, except for this thing. –  Jmlevick Jul 18 '12 at 18:28
add comment

2 Answers

Research indicates that there are issues between Thunar and Nautilus.

Replacing Thunar with Nautilus?:

The desktop component doesn't play well yet with the filemanager because it is using the dbus interface of thunar directly.

Thunar File Manager:

It does not play nice (at all) when copying out of it's own Thunar window and into the Nautilus window.

My own experience is that I cannot cut/copy/drag files directly from the desktop to a Nautilus window. I get the following 2 errors:

Error while moving "New Folder ".
There was an error moving the file into /home/****/From Desktop.
Error moving file: No such file or directory

Error while moving.
There was an error getting information about "".
Operation not supported

I get exactly the same errors when attempting to copy/cut/drag from a Thunar window to a Nautilus window.

Workarounds:

  1. Use the Thunar file manager when working directly with the desktop (cut/copy/drag)
  2. Do all of your file operations from within Nautilus itself

So even if Thunar has been completely removed from the system, you should still be able use workaround #2.

Applies to:

  • Xubuntu 12.04
  • Nautilus 3.4.2
  • Thunar 1.2.3
share|improve this answer
add comment

Try uninstalling the xubuntu-default-settings package. That did it for me.

You can also get rid of parole (the Xfce movie player) and leafpad and mousepad (Xfce text editors) and use totem and gedit instead.

share|improve this answer
    
Sorry, it turns out my desktop is actually still managed by Thunar. I'm looking for a solution to the same problem: how can I set xfce4's desktop file manager to Nautilus? –  M-J Jul 28 '12 at 15:26
    
This has nothing to do with the question. –  Elfy Jul 28 '12 at 15:43
    
I think I have it working now. Steps taken were: 1) Open Settings>Session and Startup, on Sessions tab set "Xfdesktop" to "Never" and click save session. On Application autostart tab add an autostarter for the command "nautilus -n". 2)Install "gnome-tweak-tool" and in the desktop tab, turn on "Trash Icon visible on the desktop". Now when I click on anything including trash on the desktop, it is handled by Nautilus. Hope that helps! –  M-J Jul 29 '12 at 14:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.