Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I exported a virtual machine from my work station, and I am trying to renew the ip-address at home. I put one copy on my laptop and one copy on my PC.

I've done this

sudo rm /etc/udev/rules.d/70-persistent-net.rules

and changed the MAC address, but they keep coming back as 192.168.1.165. I need them to be different because I need to run two of these exports at the same time, so I cannot afford to have the same IP.

What can I do?

Thanks.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

I'm not familiar with Virtual Box (I use VMware Player) but for the NIC config you should be able to change it from NAT to bridged. That should allow a different IP.

share|improve this answer
    
They are both Bridged. Are you saying try set to NAT first then back to Bridged? Thanks. –  user1012451 Jul 10 '12 at 1:55
    
No, NAT should pass traffic through the host whereas bridged should allow a different IP. At least that's how it is in VMware Player and I don't see why that would be different in virtual box. Can you set a static IP on one of the hosts instead of relying on DHCP? Or if possible, set a DHCP reservation on one? Oh... and before that, did you try taking down the interface and bringing it back up so the settings would take effect? –  Corey Whitaker Jul 10 '12 at 1:58
    
@CoreWhitake Yes I have reboot, shutdown, after taking down the interface. I even unplugged my cable, reboot, and plug back and turn on again to force it to "realize" it needs a new one. I will try to set a static one. Not sure if it's possible. –  user1012451 Jul 10 '12 at 2:01
    
Thanks. That works! –  user1012451 Jul 10 '12 at 2:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.